Maxwell for sketchup not loading on Mac with Sketchup 2022

getting error trying to load Maxwell. Any help is appreciated.

Error Loading File /Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/Maxwell/init.rb

Error: #<LoadError: dlopen(/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell/bin/osx/mx_r27.bundle, 0x0009): tried: ‘/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell/bin/osx/mx_r27.bundle’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)) - /Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell/bin/osx/mx_r27.bundle>

/Applications/SketchUp 2022/ `require’

/Applications/SketchUp 2022/ `require’

/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell/init.rb:157:in `<top (required)>’

/Applications/SketchUp 2022/ `require’

/Applications/SketchUp 2022/ `load’

/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell.rb:41:in `register_extension’

/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell.rb:41:in `module:MX

/Users/thomasstewart/Library/Application Support/SketchUp 2022/SketchUp/Plugins/maxwell.rb:23:in `<top (required)>’

From what I can see in your error message, it looks like the extension isn’t compatible. Have you tried contacting the Maxwell folks?

no not yet. will try that… Thanks

If you are using a M1 Mac, some extensions that aren’t compatible with M1 native mode will work if you start SketchUp using Rosetta.


The error dump pretty clearly says that the loader couldn’t find a bundle version compatible with your M1 (arm64e) Mac. You should try starting SketchUp using Rosetta, as @Anssi suggested.