Materials Editing in Mac missing

Thanks Dave for the summary of material editing on the Mac. I was just viewing your latest Design, Click Build video on the same topic. I tried creating a new folder of material from an imported image as you describe above:

In order to create a new collection/folder of materials from the imported textures, set the Materials window to Colors in Model and drag their thumbnails to the palette in the lower part of the Materials window.

I was unable to drag the newly created material thumbnails from the colors in model section down to the lower pallet. It just rejects it. I can drag a color thumbnail to the lower pallet, that works fine but not a material. I have tried this using both SU Pro 2016 and 2017 with the same result.

I am wondering if the ability to drag a newly imported texture material ever worked on the Mac at all. From the link below, from 2015, posts by Barry, he indicates this feature doesn’t work. That is, you can drag a color from the colors in model thumbnail into the lower pallet but not a material from a imported texture.

I am using a MacBook Pro (Retina, 15-inch, Mid 2014), 2.5 GHz Intel Core i7, 16 GB 1600 MHz DDR3, MACOS Sierra 10.12.6, SU Pro 2017.