Matching front and back face colors

One issue with sketchup that has bothered me for years… When applying a color/texture to a solid object, the back face (inside of the solid) does not take the material. This is not that big fo a deal, EXCEPT that these back face materials show up when viewing the model from a distance as well as along edges in renders. For example, if you have a series of solid cubes textured red, you will still see the white default material bleeding through from many angles and in image exports. Really kills the cleanness of the overall look.

Obviously, I could go into a group or component and start navigating inside the object to apply the material, but there must be a better workflow for this.

Hoping someone here knows of a simple and efficient solution or perhaps an extension/plugin to solve this.

you can change the style so all back faces are black and the edges to same as material…

john

Hmm, that is an improvement, but still does not allow for the clean, flat look of having edges turned off. With edges off in this method, you still get that black backface bleeding through. With edges on, the edges match the material color but do not account for shading, so they stick out and do not blend in for a clean graphic look.

The only way to eliminate this (that I know) is to make the back faces of all objects/solids match the front face. This is the problem I am trying to solve.

There is an extension called “Auto Back Color” that might help you out. It’s not free ($4.50) but it sets the back face color to the front face color with click.

https://extensions.sketchup.com/en/content/auto-back-color

Very helpful, thanks!

Note that if you use your materials to calculate their areas, faces with both faces painted are added twice.

A VERY simplistic fix for this is as follows.
In the Ruby Console copy/paste + enter this code.
ALL faces will be edited to use the same material on the back as is set on the front.
It is one step undo-able.
NOTE that if you have reversed faces it might not do what you want - back faces might overwrite reversed-fronts.
Having a scene-tab using the View>Monochrome setting [with a distinctive back-face material] is VERY useful to ensure that your model has no reversed faces, used frequently as you model - before materials are ever considered…

model=Sketchup.active_model
model.start_operation("MATfront2back", true)
### In Model's faces
model.entities.grep(Sketchup::Face).each{|f| f.back_material = f.material }
### In compo/group's faces
model.definitions.each{|d|
  next if d.image?
  d.entities.grep(Sketchup::Face).each{|f| f.back_material = f.material }
}
model.commit_operation
puts

@TIG
Old post I know but I’m Curious.
I’m guessing i can just use this then to do the opposite

model=Sketchup.active_model
model.start_operation(“MATback2front”, true)

In Model’s faces

model.entities.grep(Sketchup::Face).each{|f| f.material = f.back_material }

In compo/group’s faces

model.definitions.each{|d|
next if d.image?
d.entities.grep(Sketchup::Face).each{|f| f.material = f.back_material }
}
model.commit_operation
puts

Therefore putting the back material to the front?

Yes, but you run the risk of losing any uv-remapping of textures on faces during the swap over.
And of course with this method the faces still stay wrongly oriented - which will trip up most renderers…

PS: please edit your post and format the main part as ‘code’ [6th icon] - the # characters are becoming bold title text !