Magenta axis - switching from one axis to another

I’m getting through “learn.sketchup” basic course and having a problems with magenta axis:

  1. choose Line tool, create a starting point
  2. pointing some other edge (i want too use as a reference), pressing Down arrow.
  3. press Down 2 more times to turn off the current magenta axis
  4. pointing a new edge, pressing Down arrow.
    Getting the old axis from step 2) again.
    I can create new lines and point different edges, but all will be drawn by axis from 2)
    Sometimes it switches edges (on a random), but in most case it does not. So i have to try to choose the correct edge 3-5 times. I’m not pointing on a middlepoint or an endpoint, so it’s not the case.

Like: this:
I pressed down button hovering the cursor over the edge of triangle (black point), but it’s still using the axis from the left part of a screen.

I can press Down 3 more times (1st to switch 90, 2nd to turn off, 3rd to activate the magenta axis), but it’d do nothing, If i move a cursor back and forth along the edge, it’d most likely switch after next 3 Down’s.

Is it my fault somewhere, or else?..

It is not your fault, this is what the ‘Inferencing engine’ is all about.
SketchUp senses whether you draw perpendicular or parallel to an edge you hovered over → hence turning the new edge magenta.
And it stops the new edge according to where the cursor is.
It is hard to say/explain what exactly happens here without the model.

In general: holding down [Shift] when magenta is On keeps magenta active as long as you hold down [Shift]. Also fat black when hovering over a face while drawing and then holding down [ Shift].

Practice will be the key to success.

yeah, i got the idea how it works.
but i can’t get, why it does not switch form one axis to another when i need it.

the model is just stock from the lesson (4th page):
12-Inference Locking 1-Basics.skp (138.3 KB)


Pressing only Down button - 2 times to turn off the magenta axis, then 1 time on the edge
As you can see, the axis switched only on the 3rd edge.

Two things that come to mind:

  • hovering over the desired edge
  • and doing this long enough for SketchUp to store this edge’s direction in memory

Also magenta isn’t an axis. It’s entirely depending on the edge you were over: then giving the options parallel and perpendicular to this edge and non, not taking memory into account.


guessed about the time too, but no matter how long i hover - it doesn’t affect the switching.
looks like moving the cursor along the edge do the thing. Though, not very comfortable…

in the lesson it was told just “point on the edge and press Down”, so i thought I turned off some setting, that allows to switch that way, or something like that.

i had “magenta axis” in meaning “guide line”

Anyway, thanks for the help!

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.