Lighting problem

Hello.
I’m very new to Sketchup and I have run into an issue I need some help with.

When I zoom, change the camera angle, or orbit around my model I notice that certain parts of my model darken or lighten, depending on the angle of my view.

The main thing I noticed is that when I my view is perpendicular to a flat surface, that surface looks normal, but when I look at the same surface from an angle it looks darker.

Is there any way to turn this off so that every part of my model looks the same? I do not need any lights or shadows of any kind. It is merely to take some screenshots.

Thanks in advance!

This might be what is happening.

1 Like

As far as I know, there is no way to turn this off. Since the main concern is generally making sure that faces have the proper orientation, some folks set the back side of the face to red or some-such to make it clear which is which no matter how you’ve rotated the view. Sometimes the front (white) face looks dark enough to be the back (blue-gray) face.

The closest I’ve been able to get is to change the “View >> Face Style” to “Hidden Line” and the “View >> Edge Style” to “Edges” and “Profiles”.

This is really important, yet really difficult concept for some people…

It would be helpful if you could post a sample SKP file or at least a screen shot showing exactly what you’re seeing. As you can tell from the posts before mine, we aren’t exactly clear on what you are describing.

It could be that you have Use Sun for Shading turned on. By default, though, the light should appear as if it is coming from the camera so when you are looking square on to a face, it will appear lightest. This shading is useful because it provides the sense of three-dimensionality on the 2D screen.

You can get rid of the shading by doing as Jim suggests and set the Face Style to Hidden Line. If you have textures you wish to show, however, that won’t work for you. Another option is to turn on Use Sun for shading and cross up the Light and Dark sliders. You can then use Shaded with Textures for the face style and still not have the shading.See below.

Of course if you are actually showing back faces instead of front faces, you need to correct their orientation.



1 Like

Thanks Wade!
That did the trick.

1 Like

SketchUp has two “lights” that can be used when viewing your model and that create the shading that helps you visualize better what is happening in your 3D space.

The first of these is fixed on your “camera” and doesn’t have any options you can configure. It makes faces that are turned towards you look lighter than others that look more to the side.

The other is the sun. Its direction is controlled via the geographical location and time zone of your model and the date/time sliders in the Shadow Settings dialog, and its intensity with the Light and Dark sliders.

If the shading disturbs you, you can make the model look almost totally “flat” by turning off shadows, checking the “Use Sun for Shading” box and setting the Light slider to 0 and the Dark slider to about 80%.

Anssi

2 Likes