Layout PDF export "page range" not working

I am trying to export a page range from Layout as a PDF file. I select Export format PDF and chose a page range. When a export pages 1-3 I still get all the pages in the PDF document.

Anyone who has solved this problem?


How about some screenshots or an animated gif of what you doing…?

I attach screenshots here, it’s really a super basic function that for some reason isn’t working for me.
Skärmavbild 2023-04-19 kl. 19.49.40.psd (5.0 MB)
Skärmavbild 2023-04-19 kl. 19.50.18.psd (3.4 MB)

Once I have gone through the steps in these Screenshots I still get a PDF with all the pages instead of the page range 1-3. Any idea what might be the problem here?

Why did you share a photoshop file, can you just make a screenshot and share it or export the psd file to jpg?

Oh sorry, I attach PNGs here.



Your second image didn’t upload, hence Paul showing you the “proper way” when you actually used it :wink:

that’s weird, I just did a test, on a 3 pages file, I asked to export only pages 1 and 2, and it gave me… pages 1 and 2.

just noticed, you are using SU 22 ? I just tried with SU 23, hold on.

edit : yeah, tried on SU 22, a 4 pages layout file, and I was able to export the first 3… and I’m also on a mac. what version of macOS are you on ? trying to find the variable between your machine and mine.

Hi, yes I had to wait a while in between, I am a new user and only allowed to attach one file first and then after a certain time attach another file. I am on macOS Ventura 13.0. And you?

I really don’t get what’s wrong with my setup.

So when you click ok what happens ?

could it be a macOS issue ? we’ve had those in 2022 with exports that gave white shapes in pdf.

I didn’t install the lastest update yet, I usually leave a few weeks pass so I don’t run into nasty bugs.

It exports a PDF with all the pages and that PDF opens.

Might be, good idea! I will try to update my OS tomorrow and see what happens.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.