Layout export to PDF

The included one (in 2022, I have not upgraded) does not work… if I knew how to get at the existing PNG I could try and make a new one - but I can’t find where they are stored.

If you print directly from LO to a printer does it work, or have the same problem?

Here’s a long shot: How are you making the PDF’s? With LO’s export to PDF function or the MacOS print dialog > save as PDF? If you’ve only done the former, try that later just to see if it does the same thing.

BTW, the approach you use is one I’ve used in PowerCADD for ages, but PC9 isn’t compatible with anything past Mojave, and PC10 isn’t released yet, so there’s no way to test with PC if the same thing happens independent of SU/LO in the newer OS.

Did you have JPEG compression enabled in your PDF export options? JPG images don’t support transparency. It worked for me. The viewport under the dot screen is vector rendered

Yes, doesn’t work. You are on Windows though… we are discussing what looks to be a Mac problem.

Yeah. And I my hunch missed the point. The result looks OK on Windows even with JPEG compression enabled.

Thank you to everybody for trying to resolve the transparency issue. Correct, I think it’s a Mac/layout issue. Hopefully they can get that fixed sometime soon.

It appears that the latest SketchUp update, resolved the transparency issue when exporting to PDF on my Mac. Thanks for everyone’s help. It appears Sketchup corrected this…

2 Likes

Hey all,
I have recently run into an issue where if I try to print my layout, Save my layout, or Export my Layout, I get the wheel of death… I’m. using Mac OS Ventura, but this happened before the update.
I appreciate any help on this, I can’t upload the file now as its frozen.

Disable Output Override in Document Setup>Rendering.

Please correct your forum profile. SketchUp for Schools is web based and available to school children. It does not include access to LayOut.

Hey Dave,
Thank you for your reply, but it is already disabled, is there anything else I can do?

Try exporting it to a local folder instead of iCloud.

Thank you Dave, I am fining an overall delay with my layout program, I think it is because in inserted product images that made the file bigger, is there a work around this?

well if it is indeed your photos that made layout slow down, you could try to resize them prior to insertion.

I’m not gonna go into the technical pixel / dpi thing, but there is a simple trick :

When you import an image into layout, if you need to reduce its size so it fits your need, then it’s a sign you could rescale it before importation.

if you reduce it’s dimensions by 50%, you already remove 75% of its (useless) weight.

As @ateliernab indicated, you could resize your image if they are the issue. I have seen sluggish LayOut files from other users who have inserted a large number of hi-res images. Reducing them to a reasonable size in an external editor has fixed that. Maybe that would help in your case.

Doing it before inserting them might be easiest if you know in advance how large the images need to be on the page. There are batch image resizing tools out there. You can also edit them individually once you have them in LayOut by right clicking on the image and choosing Open with [the image editor you selected in Preferences].

1 Like

oh yeah off course, that was a complete brain oversight on my part :smiley:

that way, Layout won’t have to process a 4000px image scaled down to 2000px, it’ll directly process a 2000px image.
could help a bit. worth a try :slight_smile:

1 Like