Layout 2018 Export to PDF is cropping and squashing text


#1

Hi folks

I have a Layout 2018 file of 14 sheets, with each sheet made up of one or more scenes, all set to specific scales.These are a mix of plans, 3D models and details, with labelling generally done in the SketchUp Pro model (as the text options seem to be rather limited in Layout).

When I print to Adobe or export to PDF, the scenes are being corrupted - either cropped to remove some of the text, or squashed so that labels overlap or are too close together. In some of the scenes, the labels have also been squashed together in Layout, even though they are fine in the scene in the SUP model (and the window has been updated).

Example 1:
Extract from SUP model:

Extract showing how it appears in Layout:
image

Extract showing how it appears once exported/printed to PDF:
image

Example 2 (extracts in same order):


image (Note the random chunk of another detail that appears in the scenes, despite not being in the SUP scene)
image

Any ideas what might be going on, and how to resolve?

Many thanks,
Rob


#2

Would you be able to share the LayOut file so we can take a look? Understood if you can’t make it public. You can share it via PM. It’s probably more than 3 Mb so you can upload to Drop Box and share the link.


#3

Hi Dave
I’ve PMd you with the files. Let me know if they don’t arrive.
Cheers,
Rob


#4

OK, Rob. I’ve had a look at those viewports.

First the excess bit of geometry. It comes from an excess viewport that was modified so that the SU camera is catching part of one of those circles over to the far right. Here I’ve dragged that viewport over to the left.

After reselecting the viewport so it is linked to the scene.

Your viewport boundaries extend way beyond the part of the model you need to show. In this case that made it look like that excess geometry was part of the the viewport in the center.

As for the text issue, I set the camera for the scenes in SU to Parallel Projection, reselected the viewports so they aren’t modified, and set them to render as Hybrid instead of Raster. That Orangery viewport now looks like this in the PDF.

No cropping or squashing of text.

You mentioned that text options in LayOut are very limited. How so? I don’t see text in this document that I wouldn’t prefer to do in LayOut.

One thing I note in your LO file is that all of the viewports show the scenes as modified. This isn’t a good workflow because it damages the link between the SU scenes and the viewports. It’s much better to set up the scenes properly in SketchUp and not modify them in LO.

I suspect the modification you made is to click on Ortho so you could set the scale since you have the camera set to Perspective in SU. It would be far better to set the camera to Parallel Projection in SketchUp and leave the Ortho button alone in LO. There’s no need to select the Standard View in LayOut either.


#5

By the way, I’ve replaced all the text except dimensions for this viewport with text in LayOut.

Some of that text could have been inserted automatically with the proper setup.


#6

Thanks Dave - that’s a whole heap of new stuff you’ve taught me.
I’m a relative newbie to SketchUp and come from a CAD background (which probably explains a lot of my bad habits…
Rob


#7

I’m glad that helped.

I wondered. :slight_smile:

I expect it’ll take unlearning some habits you developed with CAD and learning the way things work with SketchUp and LayOut. It seems the vast majority of problems people report with both programs come from trying to make them work like AutoCAD or other programs instead of learning to work with them as they are designed to be used.


#8

The trouble is I still have to use CAD as well…

One thing I’m struggling with is how to set a specific scale in SU once I’ve set the camera to parallel projection? I can’t see where to do this.


#9

Clearly CAD thinking.

In SketchUp you don’t set a scale. You normally draw everything full size. If you want to show the model at a specific scale, you set that in LayOut for the viewport. Scale is a paper space concept. SketchUp is model space and normally everything is done at life size. There are some exceptions for modeling very tiny things but from an architectural view, full size should be the main approach.

Looking back at your model, is it appropriate to dimension the thickness of the Orangery step and its bullnose in meters?


#10

Probably not - I think this was one of the first details I did so I probably just went with the default settings…

Still struggling to set the scale in Layout:

Scene is set up in SU with the camera set to parallel projection.
Save the model.
Insert new viewport in Layout.
Adjust the viewport (is there a way to jump straight to a specific SU scene?)
If I then right-click and try to set the scale, it reverts to ortho (which you said was a bad approach).

Sorry - I’m a bit stumped - can you point me towards a tutorial video on this?
(Already over-budget timewise, and client hassling me to get this sorted…)

Rob


#11

What are you doing when you “adjust the viewport”? Look in the Deault tray on the right side of the screen. At least it should be on the right side. Find the SketchUp Model panel. You can select the scene from the drop down list.

When you select the Parallel Projected scene, it will automatically become an Ortho view. Just don’t click on the Ortho button or select the Standard View from that drop down list.

You can also select the scene from the Context menu if you prefer.

Hopefully that’s enough to get this project sorted. After you do, let’s connect via PM. I can show you some basics to get you going in the right direction. As for LO video tutorials, there aren’t a lot of them. There’s a book by Nick Sonder and Matt Donley that is good but that won’t help you right now.