Layers not showing on export to pdf?

I’m trying to export a file from Layout to PDF. I have a floor plan over a topo and it works great. When I move the floor plan to the rear to show the topo through the floor plan, it works perfect in Layout but the floor plan is not visible in the PDF. It has worked in the past, but now its not. Any suggestions?

Can you share the LO file so we can see what you are working with?

What operating system are you using? Your profile indicates iOS but LayOut doesn’t run on iOS.

macOS Monterey on a MacBook Pro

Please correct your forum profile.

And again share the LO file so we can see what you’ve got.

I would rather not share my file because it has personal information.

You could remove the personal information. Without the LayOut file it’s only a guessing game.

The file has a lot of information through out the file. It is not just this file. It has to be a setting some where because it is doing it for all of my files and it hasn’t done that until today.

Is there a setting that could effect it?

How are you creating the pdf file?

File/Export/select pdf

The same as all the ones I’ve done in the past

Could you make a sample file then. Have you tried Mac Print to PDF to see any difference?

File/Print/Save as PDF fixed it. Why did the export button stop work?

I don’t use the export method usually. I find the print method to be WYSIWYG most often. Maybe checking the pdf export settings. it could be it’s not picking up the raster information effectively?

I will check it out, thanks for the fast replies. Its at least working now.

Using the bring to front/send to back commands work on objects that are on the same layer. It is a safer method to place the objects or views on different layers.
Some other things that might be at work:
Raster, vector or hybrid rendering?
Is JPG Compressin on in your PDF export settings? (JPG images don’t support transparency)