Keeping trimmed faces on correct layer


When using the trip tool on two solid groups, each in a different layer, the faces of the trimmed solid end up on the layer of the trimming object. This took a while to work why I was being left with faceless solids!

Is this a bug, or intended behaviour?



It sounds like you might be using layers incorrectly. Faces and edges should remain on Layer 0 and Layer 0 should always be kept as the active layer. Only groups and components should get assigned to other layers. Then, when the trim operation completes, the faces in the trimmed group should also be on Layer 0.

I would say this is intended behavior because it does what is expected of it when layers are being used correctly.


Thanks, but if that’s the case why is that not enforced? That doesn’t sound like a sensible way of using layers to me.

Where is the documentation saying that’s how layers should be used?


There have been a lot of requests for the option to lock Layer 0 as active. There are a few rare use cases where this rule can be broken but in the vast majority, the best rule is to leave Layer 0 active at all times. It’s also very freeing because you don’t need to be chasing the active layer as you work.

It is described in the Help article on Layers. I’ll find the link.


See the above and especially:


In addition to the written documentation, see these brief videos:

SketchUp Training Series: Layers

SketchUp Training Series: Components


Ah ha! … I will change my ways :slight_smile:

Thanks Dave!


As I say, I think you’ll find it is actually a great workflow because you don’t have to continually chase the active layer. Less work and fewer opportunities for errors.


The advice is keep Layer0 current and then all Edges/Faces are assigned to it…
Group or make components of this geometry.
Assign other layers to those ‘containers’, which can then be used to control visibility.
Geometry is NOT separated by layers, to do that use Groups/Components.

The exceptions are things like text and dimensions which can be assigned other layers and their visibility control separately…

If you have lots of wrongly assigned geometry then there are tools to painlessly fix your model…

Consider getting/installing my LayerWatcher…

  • It has a background process which questions if you choose to reset your model’s Current-Layer away from “Layer0”: although you can still do it, at least you were warned !
  • It always assigns “Layer0” to all [manually] added Geometry [Edges and Faces] irrespective of the model’s Current-Layer setting.
  • If there is a suitable Selection you will get additional Context-Menu items…
  • With selected containers [Groups/Components] - Context-Menu == ‘Explode-To-Layer0’ [this is because SketchUp ill-advisedly assigns the exploded container’s layer to any resultant geometry]
  • With selected geometry - Context-Menu == ‘Selected-Geometry-To-Layer0’ - which defaults the geometry’s layers, and if there are ‘containers’ in the selection you are then prompted to reassign nested geometry’s layers as well…


This is Sketchup for Web/Shop, so no plugins (yet?), unfortunately.


Doh !
Sorry, didn’t read enough posts in the thread, or look at the title/tags.
But bear LayerWatcher in mind if you ever ‘go Pro’…


Unlikely, unless I’m lucky enough for them to release a native Linux or ChromeOS version! … Please??? :wink:


One of the rare cases is inserting multiple components associated with the current layer.
You’d temporarily switch to say a “Window” layer, insert a number of window components, then when done with the insert task, reset the current layer to “Layer0”.


Yes. That is true and maybe not such a rare case.

I was thinking more about rare cases of putting edges on layers other than Layer 0. There was a demonstration at 3D Basecamp where edges got moved to different layers before exporting to a CAD file that was going to be used to create different toolpaths for CNC routing. It should be noted that this should be a conscious decision to do this and not a general practice.


I remember the same discussion as @DaveR, and thinking at the time that it was an interesting example of a sort of reversed mismatch of what Layers mean in SketchUp vs CAD because the exporter was splitting geometry apart in the export based on SketchUp layer - and that was what the user needed! But, as noted, a special and slightly peculiar special case.