Just purchased, Cannot use (import error)


#1

I just purchased the iOS Sketchup Mobile viewer for use with one specific model only.

After installing it and loading the file via Dropbox, it gives the following error:

“.skp file import error
The model request is not a valid .skp file and cannot be loaded.”

The file is valid, as far as I can tell, because I open it regularly on my computer. I tried transferring the same file to the iPad via iTunes file sharing, and got the same result, so it doesn’t appear to be a network or data transfer error.

If I can’t work with this file, I will request a refund, but I wonder if there is anything I can try before giving up.


#2

Brainstorming here …

Might your .skp file be saved in a version that isn’t readable by the iOS Mobile viewer? – I recall mention in other threads the the Mobile Viewers can’t (yet) read .skp file created by SketchUp 2017 (Make or Pro).

I can’t be sure since your profile says “Make 64 bit” - but omits the Sketchup Version (8, 2014, 2015, 2016, 2017?). I also can’t be sure because I don’t have an iPad or iPhone, hence can’t test the iOS viewer at all!

Whatever version of Make you have, try saving your .skp file in an earlier version:


#3

Thanks very much for the really prompt reply. You identified the issue perfectly. After saving it as 2016, it works fine.

The only problem now is that it seems to crash when I start to move about the model. It’s a 50MB model, which I guess is too much for the iPad to cope with. :frowning:


#4

Happy to help. And thanks for marking my example as the solution!

If you’re able to load the model w/o problems, then crash on movement, try changing to a simpler face style (under the “glasses” icon if the iOS viewer is anything like my Android viewer) - the simplest is “Wireframe” before moving. When you do that, the viewer won’t attempt to render the faces during the move. You can always switch back to “Shaded, with textures” once you make the move.

You also try to simplify your model to reduce the file size.


#5

Aha. That solves the problem too.

Thank you for these two bits of advice, which now mean I have some access to Sketchup on my iPad, at last. Great!


#6

I am quite illiterate as comes to IPads, but I think someone from Trimble mentioned in another thread that there is a setting where you can assign more memory to the viewer application in your IPad/IPhone to prevent these kind of crashes.

Anssi


#7

Thanks for the tip. Unfortunately I can’t find the specific threads in which this is mentioned (I just searched), and I’ve never been aware of such a feature in iOS.


#8

Just had the same problem. Downloaded the Viewer App on my Ipad today. Still does not work with Sketchup 2017 file. Saved the file as 2016 version and all is ok. TKS