Joining in-line lines


#1

One of my most frustrating issues with Sketchup is with one of the simplest of tasks on the most basic drawing level. Simple lines. If I draw a line, and then I draw another line that is an extension of that line, Sketchup forms two separate lines. That’s OK. But usually, I want those two lines to become one. Leaving two lines often leaves an unwanted intersection that complicates the drawing unnecessarily. I can’t believe there is no way to “join” or “weld” those two lines together.

The most simple and logical way to have this work, in my opinion, would be that if I have two in-line lines, with no other object at that intersection, and I re-draw a whole line the length of those two lines, that action should immediately turn those two lines into one line. I’m amazed that this does not work this way now. I can not think of any reason why this should not be implemented.


#2

Of course there are ways to weld edge segments together. There’s TIG-weld in the Sketchucation Extension Store and Weld in the Extension Warehouse.


#3

There is a plugin called Weld, by TIG that does what you want.

I agree it would be good if SU did it automatically, in most cases at least.

Indeed I thought I had read some years ago that it was going to change to that default behaviour, but it hasn’t.

As usual, DaveR gets there first!


#4

Also you can heal a joint by adding and deleting an edge.


#5

It’s nice to weld edges together sometimes but there are other times when it isn’t appropriate or having them welded creates more work. I prefer welding them when I want them welded and letting them be unwelded otherwise. A keyboard shortcut makes quick work of it when I want them welded.

Here’s an example. Double the length of the little box in the red direction while keeping the wall thickness the same. Generally the Move tool would be appropriate. Try that on this box. Or try FredoScale.
Resize the box.skp (58.9 KB)


#6

There are all kinds of things you can do with extensions. The point of feature requests is to include something as part of Sketchup. And as I pointed out, it should be something as simple as drawing a line over the two.


#7

Extensions are not feature requests.


#8

Extensions are not feature requests


#9

That’s great, thanks - I didn’t know that worked. It’s almost as quick and easy as my suggestion, (but not quite!).


#10

As an alternative to @Box’s native solution you can drag the middle vertex to whereever you want with the ‘Move’ tool. So drag it to the left or right end vertex. Fast as h.ll and native.
This “only” works towards end vertices that can be referenced to, so not being completely free at he end of an edge.


Drawing a roof with pitches at right angles
#11

That assumes there is something else connected to this point, which is exactly not the case of when I want to join these two lines. So if I select a point between two lines that are by themselves to move (no other line touching the point between the two lines), it selects and moves the whole line that is selected. Unless you mean something else…


#12

What @Wo3Dan is describing is moving the Endpoint of a line.
If you use the move tool with nothing preselected it will grab an endpoint (vertex) and allow you to move it.
As you see here I move the endpoint of the join to the end making it one edge.


#13

■■■■! That’s a basic function that I never picked up and was always frustrated that I couldn’t do. I ALWAYS tried to select the point first! That was actually the first way I tried to solve my original problem but couldn’t figure out how to select just the point. That makes a huge difference. Boy do I feel dumb. It’s also funny that I was just doing something in SU where I really needed to move JUST a point (that was connected to multiple lines) and couldn’t so I came back on here frustrated about it. Thanks.


#14

@arhude and @Box, as I mentioned above, this is not the solution towards free endpoints. You cannot drop the middle vertex right ontop of the end vertex if there is nothing else there. Only close to it. There remains a very short edge, maybe even hard to spot.
@arhude, for two connected edges with nothing else at the endpoints you’ll have to use @Box’s method.


#15

I haven’t had any case where there was a line completely free at the end, so this is the solution I was looking for.


#16

Now my problem is SU17 Pro keeps crashing often when I try to do this (Move a point).


#17

There must be something else going on. I haven’ t had that problem when moving vertices this way.
Is your graphics card driver up to date.


#18

Do you happen to use a 3d mouse? I seem to remember there being a problem on some systems that caused a crash when you move the 3d mouse while on a vertex.


#19

As a matter of fact I do - A 3DConnexion Space Navigator. I was able to duplicate it too. Grabbed a vertex and moved it all around with the touch pad, then grabbed the knob and CRASH! It’s at least nice to know why now…


#20

Upgrade to 2016 or 2017 will fix it.