Issues with Chaos Cosmos Browser!

I have issues with the Chaos Cosmos Browser. Everytime I try to open Chaos Cosmos I get an error message (see uploaded image). Furthermore, I have found a temporary fix and that is to uninstall Chaos Cosmos Browser from my computer and then reinstall the newest version. This is very frustrating for the reason that I have to do this procedure everytime I use SketchUp, and I know that it should not work like this because it was fine before the problem occured. I am reaching out to you for some help to fix this permanently. :slight_smile:

Restarting does not work
The license in use is a school-license.
SketchUp Pro 2023
V-Ray version 6.00.02 Jan 17 2023
Cosmos Browser version 2023.02.28-303155

Thanks in advance!


I have had this problem last year and Chaos help didn’t help…but I remember following a video on youtube and it worked. But don’t ask me why!

Can’t find the video, but this is what I reported to Chaos in an email for their records:

  • Stop Chaos Cosmos Browser (there’s an app for it, type this in windows start bar it should find it)
  • Delete the file cpkg.db found in your Assets Download Folder/Packages
  • Restart Chaos Cosmos

Please feel free to search for another source as I am not an expert, I just found a solution and dumbly applied it.

Hope that helps.

1 Like

I followed this video: SIMPLE FIX CHAOS COSMOS FAILED TO LOAD - Sketchup Tutorial - YouTube
and it worked for me even after I close SketchUp and restart my computer. This is a permanent fix for me! :slight_smile: