Is grain direction supposed to work that way?

Hi, I am trying to understand the way I can manage grain direction efficiently and I am a bit confused. I am using materials created in OCL with “grain follows length” setting selected, properly oriented texture and “automatic orientation of parts” on. With these settings I expect to get the grain along the length of all parts. Instead of this the grain goes along shorter edge sometimes unless I manually change the axis of the detail to be according to the scheme provided by OCL (red - length, green - width, blue - thickness). In both cases length is chosen for longest side, only axes’ colours are changed and this fixes the issue for me. Is it some bug or I don’t understand the way OCL manages grain direction?

Here are the screenshots:
wrong alignment


proper alignment after I changed the axes

As you can see, the extension has the grain direction/length aligned with the red axis. I expect in most cases you’ll need to set it up that way. With sheet materials that’s not always the case, though. And sometimes grain direction with sheet materials isn’t important.

BTW, please correct your forum profile. There is no 2023 Free Plan as yours indicates you are using.

Hi @pacmanito,

I understand that “automatic orientation of parts” could be a confusing option. This option doesn’t change the texture orientation. It only chooses the longest part dimension as length and the smallest as thickness, to avoid the necessity to change part axes.

Texture orientation are just cosmetics. It’s not by default a source of data for OpenCutList. The best way to view how OCL view parts is to use the Highlight part in model tool that draws an arrow on each part.

But if it doesn’t suit you, you can make it consistent :

  1. Rotate your texture to be sure that grain is “horizontal”.
  2. Disable the Automatic orientation of parts option.
  3. Use the Smart axes tool to orient all of your parts
  4. Apply material on part instance (not on inner faces). In this case SketchUp will align automatically texture X axis along part X axis (red)

3 Likes

@boris.beaulant thanks a lot for the detailed answer. Using your suggestion I was able to achieve what I wanted. But this still seems a bit overcomplicated to me.
Now I see that OCL grain direction and OCL texture orientation are managed separately and I suppose this can cause a lot of confusion for people. Wouldn’t it better to merge those two? Or at least give us an option to align all components’ axes properly automatically? Also syncing texture orientation and grain direction requires either creating all components in the same axes system and then rotating them or changing axes afterwards. As I have my model ready I was able to achieve the desired result using second method and it seems to me that having some OCL grain orientation show toggle (like highlight tool which you suggested) inside your smart axes tool would be beneficial as it would make checking components orientation process more straightforward.
Finally I’ve had one component for which I was not able to change texture orientation at all. I tried changing axes via OCL and native Sketchup interface, reapplying material etc., nothing helped. Of course recreating such component takes only 5 seconds but I want to understand what’s wrong with it and how it happened (file attached - test piece.skp (1.6 MB)).

Edit:
BTW it seems your smart axis tool has pretty handy feature which is not documented - it shows blue arrow instead of white on details with “wrong” axes.

Rotating texture along component axes is not an OpenCutList feature. It’s just a default SketchUp behavior when the user doesn’t define any texture orientation on faces.

If you apply material to part faces, SketchUp allows you to rotate the texture. In this case, the previous useful behavior will no longer work.

Highlight tool does it too :wink:

Impossible. Visible texture orientation do not depends of a unique thing. Sometine it’s automaticaly aligned along red, sometimes it’s aligned along custom texture user orientation. It depends on where you apply the material.

There’s no miracle solution. The software can’t choose the grain orientation for you without bord effect.

Highlight details tool from parts screen is only for viewing purposes, the only available action is to open component’s OCL details (where we can change axes of course but it’s not as intuitive and convenient as smart axes tool). And while working through smart axes tool we have to highlight components one by one pointing cursor over them. So I have to go to highlight tool to get the general look and then I have to go back to main Sketchup screen and edit components via smart axes tool and repeat this procedure for every material. Having such highlight feature inside smart axes tool would help to check the model for proper grain orientation without opening “highlight details” screen for every material separately.
Some sort of “ignore grain direction” flag visual identification would also be welcome.

Generating complete scan of all parts can take few seconds on quite big projects.
A tool that take second to activate is unusable.
That’s why currently those two features aren’t merged.

Alternative way :
Auto oriented parts row display a special blue icon in parts list table. See all of them in one place and click on this icon to open Axes property tab where you can double click on red/green/blue squares to reorder automatically part’s axis to put red along length and blue along thickness. And then align texture as mentioned previously .