iPad freezes scaling image with tape measure


New user, work in construction, using SketchUp and morpholio trace to makeup plans and model details and changes.

I imported an image (screen grab of pdf plan) to new project, then used tape measure over known dimension to resize. Seen it done on a couple of tutorials online.

I’ve tried many times and reduced the image size to about 150kb and it still crashes my ipad. It’s a new iPad but just regular spec, not a pro.

Any ideas? I’ll be disappointed if iPad just doesn’t have horsepower for this command. Workflow is severely limited without it.


Hey Monty,
Make sure your iPad is up to spec…
You could also try scaling that image in SketchUp for Web, then opening the project on your iPad.

Hey Kyle,

It’s a new iPad 9th generation.

Not good enough? I’ve had no issues otherwise, maybe 20 hours of use so far.

I’ll try scaling the image even smaller before importing

@MikeTadros have you seen any issues with this function?

I just tried reducing a model using the tape measure, and SketchUp on my iPad Air also froze up. There is a peculiar sort of burnout effect over the Enter button on the Length pop up.

I get the same. If I hit the home button and reopen I get this but everything is frozen and doesn’t recover.

Thanks for the reports. We were able to reproduce the issue but we’re sing that in some cases the tool works as expected, and in other cases, it doesn’t (which is probably how it slipped through QA). These sorts of issues can be difficult to track down, so for those of you seeing the issue, can you please:
• let us know what version of the SketchUp for iPad app you’re using (you can find this info under the About tab (the SketchUp icon, bottom left) of the Home Screen?
• let us know what version of iPadOS you’re running?
• Also, if you’re willing/able, please DM me a copy of the SketchUp model that you’re working with so that we can take a look at the images that you’re trying to resize.

We will be working to fix whatever is going on as soon as possible. Apologies for the inconvenience while we work on a fix.

1 Like

Sent details as requested, thanks for the help.

FYI I tried just resizing a single line from about 30’ to 12’ and got the same thing….

Version 6.1.0 (1885)

iPadOS 15.7

iPad Air 5th generation

Thanks for the additional info!

Same for me,
ipad air 5th
ipad os 15.7
version 6.1.0

It seems to freeze when trying to resize anything with the tape tool.
If you swipe to something else then come back to sketchup the dialog asking if you want to resize is there, but it is also frozen, and No appears to be bold.

Mine is working great. As expected.

iPad Pro 3rd gen.
iOS 15.7
Resize with tape measure works fine.

Version 6.1.0 (1885)

Updated from iOS 15.5 to 15.7

Issue remains the same

I see the burnout on the num pad after entering the dimension but not seeing the freezing up nor the crash. I am on an iPad Pro 12.9 4th generation iOS 15.7.

Good(ish) news. We’ve tracked down the issue and have a fix in the works. I’m expecting that we’ll be able to include it in our next update.


That’s great! Thanks for the update :+1:

Hi all - same problem here (iPad Pro M1, 1T memory, SU 6.1.1 1894).
Downloaded the free trial version just yesterday, hoping to be able commit to a paid annual subscription by Nov 5th when this trial ends.
Any update on a fix?

Latest version came out 5 days ago, so I’m guessing next update will be after November 5th.

@apostolos.karelis We are working to issue a release that includes a fix for this issue. I am hopeful that it will be available before your trial period ends.