Intersecting two components

Hello there. Its been a while since i last posted. I have been experimenting with the types of intersections in SU pro and i seem to have gotten stuck.

in the photo below, you will see that i have two components, the ring, and the boss extrusions. I am trying to union them together, while getting rid of the ring section inside the boss extrusion. I can do this with solid tools easily, but i thought i would have a go at the intersect faces options.

I have tried a few ways and have failed to no avail. Here is the file. I am looking for some help of understanding what the steps are that need to be taken.


ring and boss union.skp (226.7 KB)

From what you say I get that as a result you want an object that can be (is) grouped as a solid.

You have two solid components.
You need to (in this case) have all the geometry in one context and then apply ‘Intersect Faces with…’. This operation creates edges in the current context.
So explode all > select all and ‘Intersect Faces with… selection (or context or model)’ > then clean up the interior of the tubes > and group all that is left, to get the solid object.

You want to make a solid tools union: The difficulty is that the small rings are flush with the larger ring on the bottom. You will end up with a single face there and it will not be easy to remove the excess. So I would push-pull the small rings down a little bit. Then perform the union. Then push-pull the excess of portion iniside the small rings so they disappear. Then push pull the small rings back flush with the remaining faces of the big ring. Where the same distances are used, P-P is fast with double clicking. I see some excess edges are left that have to be cleaned up inside the small rings.

1 Like

I would do 1 and array copy the other 5.


I am having issues still. I try what you mentioned but i get some odd goings ons with the geometry.

I have tried intersect with model, context and selection and all yield the same result. I know i can make one and array it 5 times, which i have done in the past with other projects. But for this, i am really stuck on wanting to get it to work with intersect faces haha…

thanks. maybe im copying the wrong part?

I try to do this but the intersect faces does not want to work for me. Are you copying the ring and intersecting it with the boss extrusion or the other way around?

Here are screen shots of what happens to mine. The disk is for reference only:

I intersect the faces first.

As shown in the photo, you can see how the boss feature broke the geometry of the ring and edges are created. Supposedly…

But, as you can see, if i select the top portion of the inside, it selects the entire top edge of the ring, even though edges and faces have been created. It will not let me select an individual face. I am single clicking…

Now, if i select a single edge, which it allows me to do. I then try to delete ONLY that edge and it deletes the entire ring on the upper portion, but keeps some of it on the lower portion.


I do not know why it is doing this. On other files, i have not had this particular issue before… at all. I have completed the project as of last night using solid tools, but now i am wanting to get this figured out this way… because its driving me crazy. I have tried to just make one, like you did, and then copy, but it wont even let me do that…


Try the intersection showing hidden geometry. It sometimes works better that way, and if the joins are not entirely successful you can locate problem areas. Drawing over even one existing intersect can sometimes affect the whole previously single face.

1 Like

ok, after i finish studying for my dynamics exam, ill give it a go. Thanks:)

My solution doesn’t work in this case. And I’m still puzzled as to why intersecting faces with … doesn’t work properly, even with groups and then pasting the resulted edges in the right context. Ring-faces just won’t split. It’s also not a matter of size of the geometry. The ring is huge.

Odd that you get that result. It can be done either going directly into solid tools or using intersect with model, and I also tried making a single portion and duplicating. That worked fine for me.

It is strange and drives me crazy haha. Solid tools works fine, but any method of intersect faces is not working.

Going out on a limb, but could other programs or processes be messing up things in the background?