Intersect Faces misses some facets of cylinder/plane intersection

Hi all,
I just recently started trying to use Intersect Faces to punch some holes through an object. It mostly works, for several holes, but when I run a smaller diameter cylinder through some countersinks created by larger diameter cylinder ends, one of the two intersections on the thinner cylinder keeps missing one of the facets, so that outer end can’t be removed to create the hole. I’ve recreated the inner and outer cylinders and repeated the process many times, with the same result.
Tried to add some screenshots showing the overall geometry and working down to the problem area, but I’m too new here and it’s only allowing me one attachment, so…

Lastly is a shot of the small diameter cylinder component, after the Select All/Intersect Faces/Model operation. You can see that the intersect line at the far end of the cylinder is incomplete, missing the line across one of the facets. (the upper intersect works fine)

Any suggestions?

Maybe it’ll let me spread the photos into replies to my own post:
This shot is a wireframe view of a big hole through that worked, and the countersink holes with the smaller diameter cylinder in place, ready to intercect.

Lastly, here’s the shaded view looking into one of the countersink holes, showing that its intersect with the primary surface was properly formed and removed. (the other countersink looks the same)

Well, guess I answered my own question. I saw on another post that scaling the whole model up can help with intersect issues, so I scaled by x10 and the identical operation worked. Attached screenshot shows the resulting correct view down the countersink and narrower bolt hole.

Any explanation from the wise ones why this happens? (or direction to another post where this is explained) The original model was in mm, with the narrow cylinder diameter = 4mm and the outer 7mm, so 40 and 70 in the expanded model. Is this a floating point issue? I assume Sketchup uses double precision, seems like the original or expanded size should be fine.

I suspect that some faces generated by the intersection have one or more of their edges that are too small. This prevent the face from forming. Try scaling the model up by a factor of 10 or 100 or even 1000. Then, when done scale down by the same factor. Surprisingly, SketchUp has problem generating faces with too small edges but will maintain closed faces when scaled down even with edges below the lower limit.

If unsure, upload your file here on the forum to get a better opinion.

Yeah, it worked fine when I scaled up by 10