Importing to SketchUp from ArchiCAD - Model Off-Axis

Hi everyone,

I recently imported an ArchiCAD model into Sketchup. The model was created in ArchiCAD slightly off-axis, to attempt to simulate ‘true north’ (doesn’t work well, wouldn’t recommend it). By the time I got to the model, it was too late to re-orient the axis in ArchiCAD.

So my question is - is there a way to reset the entire model’s axis in Sketchup?

Thank you in advance!


Here’s another screenshot, showing how many separate groups there are:

I think the best option is still to take the whole model, move it to the SketchUp model origin and rotate to match the SketchUp axis. You can also move the axis to match the model, and with SketchUp 2022 set up plan and elevation views that match the changed axis directions.

So I rotated the model to match the axis. The main issue is that each individual group is still off-axis:

Would this be solved by moving the axis to match the model? Thank you!

Moving the model axes won’t fix this. You would need to change the axes for the components.

You might try running Eneroth Line Up Axes. It should be able to fix the off axis components to align with the model axes for you.

That extension worked! Thank you!


1 Like