Importing shapefile and geolocation satellite images correctly in SketchUp

I have a shapefile (also other relevant files, shared in Google Drive) which I imported to SketchUp Pro (version 23.0.419 64bit).

At first I loaded satellite images from geolocation menu as a base map. To import shapefiles, I installed spirix_shapefile_importer.rbz from this web site. CRS of the shapefile is converted into WGS84 (EPSG:4326) and I chose ‘Yes’ in Geolocate when importing the shp.

However, location of the imported polygons does not fit to the satellite images.

I want to show correcto location in QGIS but I cannot put more than two images…
I think it happens due to several reasons:

  1. Location of imported satellite image is automatically set at the center of the XYZ axis.
  2. Location of shapefile is automatically aligned to get closer to the XYZ axis. I checked this behavior by adding some polygons at left-bottom side. If I add some polygons, location of imported polygons were adjusted based on newly added polygons.

I am not sure which caused this issue but it returns polygons with wrong location. Is anyone who faced the same problem or who solved this issue? I need to align the shp to fit into satellite image (locate shp to represent geolocation correctly).

1 Like

Can you provide the SHP data as well as the geolocation?

I do not have satellite image as local file but just add it from geolocation menu.
I checked sketchup menu but we can only chose “Add location”, “Clear location” and “Show terrain”. I think I cannot save the downloaded image in my local drive.

Does it mean I should prepare my own image such as geotiff from other source so that I can overlay the image and shp correctly?

Shapefiles have no specific units. When you first select the file, what does it show in the popup?

For example:


I see, this is the default values when I load the shp file.

The data doesn’t look like GPS coordinates. If they’re not GPS, then the import can’t be geolocated. May I ask where this place is?

Like this:


After re-reading everything, I see that you stated the data is in WGS84 format. The importer should be using that as well, but the reference point of the SketchUp axis is in the lower left corner of the entire import, not the center. The geolocate option is used to alter the geometry to fit the location on the Earth. If you grab all of the groups and drag them to the correct location, do they line up as they should?

This feature was added in the middle of this thread:

Yes, if I manually move the imported polygons on to the satellite image, it almost fits.

Does it what you mean in “this fature”?
I tried to find the feature of the importer but could not get it.

By the way, location of this area is here:

hmmm…in your GIS program can you check if the dataset is referencing a vertical datum? If so, you may want to reproject the imagery so that there is no z-value to the data, then exporting the shapefile again.

I didn’t mean to leave you hanging for so long. I’m trying to figure out how my code works. It’s been too long since I last fiddled with it. :rofl:

Sorry for the late reply! I was out of the office after that.
Is there anything that you need to confirm to check the cause of the issue?

I am using QGIS and the shape file refers EPSG4326 WGS84.
I am not sure how to check whether the data set refers vertical datum or not, but the shapes were drawn manually based on satellite image by myself. Thus I suppose it does not refer vertical datum (no z-value) in it.

Does “reprojecting the imagery” mean clear location and add location again in geolocation?

I found shapefile data for Cambodia, but it doesn’t seem to include Lovia. Is it possible to share your dataset?

Actually the shared file in Google Drive is only the file that I am using for my project. There is no other data at this moment.

1 Like

Once again, I failed to read your original post completely. Color me brain dead. :roll_eyes:
Using your data, I manually geolocated my SketchUp model to the X[min] / Y[min] values obtained when running the importer. Using the geolocate option and exporting it as a KMZ file, this is what I get when I open it in Google Earth Pro:

I apologize for wasting so much of your time. After importing the satellite imagery, manually set the location of your model to the X[min], Y[min] values shown by the importer, this will align the geolocation data of both. As you noted, the image import centers it on the axes whereas the importer always creates everything in the +X+Y quadrant.

1 Like

Thank you and well noted!
I will check appropriate values to adjust the location.

1 Like