Importing CAD files


I know that you can import AutoCAD files with Autodesk Pro, but I wanted to know if it was posible to do it with the free versión.

I also wanted to know if when you import a 3d model, it can be modeled in blocks instead of being modeled in lines.


You mean SketchUp Pro? Then no, DWG import is restricted to Pro version only.

Do you mean modeling in groups like AutoCAD? If so then yes. You can group geometry or make components, which function the same as blocks in SketchUp.


Thank you Eric, just to make sure,

Would it be posible to import a 3D model file like the first picture instead of like the second?

(With those lines which make the model harder to work with)

Thank you


Yes, in the first image, the lines are still there, merely hidden.

You can use a combination of manually hiding the lines/edges (right click > hide) and using the soften tool.


That is good, Thank you!

Is that option available in Sketchup Shop?


I would think so as it’s available in SketchUp Free.


@imarquet - There are no settings on import that ensure clean geometry. It has to do with how complex your dwg/dxf block is to begin with, or what program created it - Revit for example may include additional geometry that CAD and SketchUp don’t use.

@liamk887 is right in that you can soften coplanar or smooth edges to hide geometry. This works on curved surfaces but if you want to hide your straight edges as well, I’d recommend Fredo6’s ‘Hide all Edges’ extension:

See below for how easy it is to hide just selected edges or everything in model:


I have a problema importing CAD files. SketchUp Shop won’t let me import .3ds, .dae, .dwg or .dxf files. I haven’t tried with .dem or .kmz and the only type of files that let me open is .stl.

Then, when I open the file, i can’t smooth all the edges at the same time and I have to do it one by one. Also, I tried to install the “Hide all Edges” extension but there’s no option to install it with the Sketchup Shop version.

Is there anything I can do to solve those problems?

Thank you!


Have you assigned yourself with th entitlement for Shop?


Note that the extension is case sensitive.

“1200 PANEL FRAME_OEM.DXF” = SketchUp Shop refused to import.

“1200 PANEL FRAME_OEM.dxf” = SketchUp Shop successful import

This had me screaming at the walls.