Importing Autocad lines & arcs


When I import my AutoCAD linework & arcs it simplifies the arcs. How can I maintain a smooth arc?
Thank You.



Depending on what you mean by “smooth” it may not be possible. SketchUp represents all arcs using a sequence of straight chords, there are no true smooth arcs.



Yes I know all arcs are a series of lines. And in Sketchup to create an arc you can specify the amount of line sections. But is there a way to take arcs inported from AutoCAD and add more line sections to be more smooth? I am working on a highway plan and the curves that are coming in are very segmented. I thank you for your help.



This is a tricky question to answer as you have to know the differences between how CAD and SU work with arcs. In CAD, which is a vector-based program, arcs may look visually segmented to increase performance but can be redrawn (or regenerated) at any time, smoothing them out.

In SU, Arcs segment as it’s not a Vector-based program. See CAD screenshot with lines touching arc at various points:

In SU’s entity info window, you can change the number of segments to whatever you want, but higher numbers increases polygons so best to use the lowest number that looks good to you. Here is a low number:

Versus a higher number:

But the arc smoothing/segmenting doesn’t address another related issue of the perpendicular lines that are meant to touch the arc. If you zoom way in, you can see a gap between the two that’s caused by the segmentation:

In CAD, you can break the lines at the intersection (use ‘BreakAll’ Lisp routine if you can) then extend the line so that single arcs are now multiple arcs:

Then after importing back into SU, you’ll see two things happen, first, since the one arc is now multiple arcs the are made up of more segments and look ‘smoother’. Second, there is no more gap between arc and line as there was before. This is especially needed when making faces. There are some extensions in SU that can help close those gaps but best to try and do as much in CAD as you can before going into SU.

Zoomed in to show indeed there is no gap between line and arc as lines now connect to arc segment endpoints.



What version of SketchUp are you using? Please complete your profile.



I am using Sketchup 2018. Yes I will add to my profile. And thank you for the information.



Now I just have to figure out how to edit my profile.



Top right is your user icon - left click>left click preferences>profile