Importing a component makes two instances

I am importing a componentt wither as a copy and paste or as an skp file and I get the same result. when I paste or import the component is displayed as two components. I don’t want two, just one. I can’t explode or singularly select one of them and delete. How do I get rid of the second image?

This is normally something you’d see when inserting a component. Upload the SKP file with the weird component so we can see what you’ve got going on.

There is text showing the “corner piece” that is the duplicate of the component I imported. I can’t explode it, I can’t erase it without also erasing the original. There doesnt seem to be any way I can isolate it and deal with it.

Again, upload the SketchUp file so we can see what you’ve got going on and help you.

Here’s the component file9150.skp (123.5 KB)
here’s the file it went into is too big to upload

Try purging the file it went into and then upload it. Or upload it to the 3D Warehouse or Drop Box and provide a link. There’s nothing wrong with the group other than it isn’t solid. That wouldn’t make it show up in multiple places.

I cleaned it up and made it solid.
9150 solid.skp (101.2 KB)

1 Like

Thanks that did the trick!

What did the trick?

Cleaning it up and creating one solid. Still had to erase the object the double was attached to and then reload the part of it that I wanted.

So basically nothing was solved.

Correct. I’m not sure why a copy part from one skp file to another would create two parts.

It’s surely something with the way you are doing it in the model but until you share that file, there’s nothing we can do to help you sort it out except make a WAG or three.

I tploaded the file to “Double Instance in inappropriate location and not individually selectable” Can’t find the URL on the uploaded file screen. Arrrgh

Save it with a new name and upload that to the 3D Warehouse.

I cleaned it up and purged it.Double import.skp (432.4 KB)
That got it small enough to post. Thanks for that tip.

Your model is really screwed up with strange nesting and because of the way you are inserting the corner component into other components. When you edit a component and add something to it, every other copy gets the same treatment. Since you are using the same component for the two horizontal parts, putting the corner piece into it and you’ve rotated one copy end for end, it’s no wonder you are seeing the extra corner piece and can’t get rid of it.

Frankly, the model shouldn’t be as complicated as you’ve made it and I think it would be easier to redraw it correctly than to fix the mess.

Hate to hear that but I think yuo’re right. Much easier to start over I thiink. Thanks for the help!

Sorry. But you’ve also got weird dimensions and things out of alignment which will add to the difficulty in fixing it. None of the model is difficult and if you build it properly, it’ll be easy enough to do.

Thanks! I’ll gring it out anew

How are you joining the horizontal rails to the angled ones?