Import of DWG autocad files loses critical detail

I’ve been using Sketchup since 2014 and my number one complaint stays the same. When I receive a DWG drawing from an architect or engineer and import it I lose the text and line weights/color which makes complicated drawings difficult to comprehend.

Almost as bad, layers are not preserved.

I don’t care about most objects but there isn’t a drawing I get without layers, text, or lines indicating details, it makes me want to switch to autocad since that is what the professionals I deal with are using.

Anyone figured out how to handle this? I see other people have complained about it.

Definitely a feature request!!

They are preserved in import. They are not preserved when you Export a 2D screenshot to DWG.

The import only imports objects that have an equivalent in SketchUp. SketchUp doesn’t support text. SketchUp has labels that are not 3D objects like text in AutoCad but screen elements.


Sketchup is not a dwg reader ! you shouldn’t need text to re-use what’s been drawn.
If you have troubles to read plans without it, there are free dwg viewers such as autodesk trueview that you can leave open on another screen (or half the screen) while working in sketchup.

As Anssi said, layers import just fine, so do blocks (that are converted to components) and even line weights depending on how they’ve been set up in autocad.

If you really need the text to be imported, you can ask your architects or engineers to explode it in autocad before sending you the file, it will convert it to line/polylines or you can even do it yourself in illustrator (or equivalent).

colors are preserved too, as coloured entities, if you turn on" Color by Material". That should be enough to distinguish what’s what in the import.

Are there any ways to get the text and dimensions importing properly? Without having to explode them in AutoCad.

You could try using TIG’s Import DXF Text. It should work with dxf files at least.

1 Like

Very nice. So SketchUp can import text. They just need to combine the two bits of code then.

Maybe. As I understand it the CAD importer is a 3rd party thing. That 3rd party would be the “they” you refer to. And while it might work for dxf files it still might not be possible with dwg files.

BTW, please complete your profile with SketchUp version, operating system, and graphics card.

1 Like

I just updated the profile info.

I wonder why SketchUp hasn’t added support for text strings after all these years.

To use an imported DWG as a modelling aid you only need the lines. SketchUp has never been intended to be a DWG viewer. In the AutoCad sense, SketchUp has no text, as model entities.

I am currently, this minute, locating existing trees on a SketchUp site model. Although I can handle it fine, for each position I have to refer back to the CAD file to find out which trees are which. I might end up labeling them in the model and it would also be nice if that text was just available to overlay in the model.

To say this is a “third party” issue doesn’t matter. Trimble could find another third party. I’m a “third party” a lot of the time. I still have to do what’s required.

Maybe you can view it in a viewer and take a screenshot (png) import that, too

There is the problem. The AutoCad file has a text object positioned beside your tree. In SketchUp you cannot put a text object beside a tree. SketchUp text placement is related to pixels on your screen. When you zoom or orbit, text keeps its position. SketchUp text is like a post-it note.

1 Like

True about SketchUp text. And if you put it in text made up of edges the file would easily become too heavy.

If i put in a screenshot will be better resolution than a pdf? I imported the pdf and it was illegible.

Setting the max textures in [menu] SketchUp > Preferences > OpenGL might improve.
It all depends on what type of viewer and what monitor if you take a screenshot.

1 Like

When I’ve needed info from a PDF in a program that didn’t handle PDFs, I exported that PDF page or pages from a PDF reader as a bitmap of whatever resolution that would be readable (300 dpi), brought that JPG or PNG into an image editor, cropped it as necessary and then brought it into its final destination.

No, but I can make good images. The problem is SU limited resolution. This was a large site. Certainly I can cut the image up etc. By that time. I’ve already done it the other way.

You can go into windows/preferences/ OpenGL and check “Use Maximum texture size”. This will help sharpen up most imported CAD images enough to work with. But when you are done you need to turn this function off to avoid issues with your graphics card.

1 Like