I just want to specify Length, Width, and Height of a selection, group, whatever


#1

I’ve been fighting with Sketchup for 2 hours, having imported a component from the 3D warehouse.

I want to make a selection, and have an inspector pane that tells me about that selection. Most importantly, what the size of that bounding box is. Then it should be easy to just type in what the exact L,W,H should be and those objects be scaled accordingly.

The scale tool is useless. I don’t care about percentages, I want exact measurements. Then you just have some extra UI component that asks for which is the ‘anchor plane / point’.

this tape measure tool and so forth isn’t really helpful because it scales in all directions. Furthermore the tutorial information is out of date, and doesn’t mention you have to un-toggle first so it’s not creating guides.

I really don’t understand how everyone thinks this software is intuitive. It shouldn’t take 2 hours to accomplish a trivial task if something is intuitive. Especially given I’ve even searched for how-to’s and even that doesn’t work.

Very frustrated!!!


#2

Use the scale tool pull one corner let go and type in the full measurements including the unit separated by commas and hit enter and it will scale in 3dimensions to exact sizes.


#3

won’t allow it. It only allows percentage values for me.


#4

Then you are doing it wrong.
Read what I wrote and try again.

Try this to start, grab middle handle on one side, drag it a bit then let go of the mouse fully and type 100mm and hit return/enter. And that length should become 100mm.


#5

“You’re doing it wrong”… the motto of intuitive software! :lol:

I’ll try again.


#6

Intuitive and guessing are two very different things. There are many learning aids available.


#7

You need to make sure to include the measurement. If you just type a number, then it will use that as a scale factor. If you include a unit of measure, like @Box pointed out, then it will scale so that the direction you are pulling is that exact measurement.


#8

You have three options to choose from:

  1. a corner grip (there are 8) which needs the input of three values devided by ,
  2. a mid “edge” grip (there are 12) which needs the input of two values devided by ,
  3. a mid “face” grip (there are 6) which needs the input of just one value

Omitting the units at the end of each value interprets your input as scale factors

Here you see a selection box that needs to be scaled to say 4m by 3m by 1m
Pull the grip as shown by the arrow to arbitrary size. Then type 4m,3m,1m and hit [Enter]


#9

I did a mid-face grip and tried to put 101.2" and it didn’t like that. Because as soon as I hit shift (to get to the ") it changes and interprets me wanting to do something else.

I then put 101.2in and it didn’t have the intended result at all. It stretched it probably by a factor of 101.2

My point was, if it’s intuitive, we wouldn’t even be scouring through forums trying to figure out how it works.

But anyway, I appreciate the help.


#10

Furthermore, I can’t just click on a bounding box and know how long it is. I have to do that dance with the tapemeasure tool and that can be pretty annoying. to find some line that is guaranteed to be on the bounding box edge, then drag it in one direction to find the exact length along that axis to another point that is hopefully the element responsible for the bounding box on the opposite face.

Just saying.


#11

This app has been a catastrophe for me so far, and I’ll I’ve tried to do is rescale someone else’s component to make sure it has the dimensions I require so I can actually sketch the thing I’m hoping to sketch.

So I don’t know what to say. I’m not an idiot. I actually design software for a living. But dont’ sell me something as being intuitive, and not make it easy to do simple things like resize an object. (Especially when there are best practices here, seen in all sorts of similar software) And provide me multiple ways of doing so for the simple stuff. Even the tape measure tool: there’s a tutorial on how to resize something, but they don’t tell you to hit the option key first to remove the very little but significant little + sign (which makes it set guides, and not be used for resizing).

I’ve actually given up.


#12

If you’d like to share the model here, I’m sure someone can help you further.
You may even be able to resize the item with the move tool.
Let’s have a look.

Shep


#13

Oh wait. You’ve already given up. Never mind.


#14

Did that. Selected a group / component. Waited. Nothing. Right-clicked, all options greyed out.

The model is in the 3D Warehouse.

It comes in with micro dimensions that don’t correspond to the actual spec sheet of the vehicle. Even if it did, it might need adjustment for a slightly different year.

I had to remove some elements and make sure the bounding box of the entire truck is just encapsulating the entire truck.

But yes, I’ve given up for now as the reason I needed Sketchup has also just changed. Anyway, it’s not a sustainable business model to support every user with each issue. I’m just making the point that the software could use some improvement when it comes to usability and ‘intuitiveness’. You’re not doing the product any favours by saying “you’re doing it wrong”.

Anyway, I’ve gone and said too much. Use the feedback or don’t. That’s just my impression.


#15

Not if you sort of end the operation (click to end scaling), only then start typing and " should be accepted. Not while still in the middle of scaling. Look at the info on the status bar down right while scaling. It says something about both the [Shift] key and the [Ctrl] key.
As I said, scale to arbitrary size, only then type the desired size.

p.s. there’s no need to know the bounding box when you start. Any beginning size (and arbitrary size during…) will result in the same size as the value(s) of your input.


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.