Hybrid Layout - Hidden Lines Rendering Incorrectly!

#1

Does anyone know what the fix is for hidden lines and objects that are rendering incorrectly in a Layout with a Hybrid render setting? The SketchUp model looks correct (I can’t post the image because I’m a new user)
When I do a hybrid render in Layout this is the image I get.
Layout%20Screenshot
It appears that hidden lines are being assigned edges incorrectly by the hybrid render. Is there any way around this? I have used these renderings in the past to produce PDF’s that I can reference into my architectural drawings. They are measurable and are able to be scaled and snapped to in my CAD program. Is there a way to get this to render properly? If there is another way I can do this with a proper image I’m all ears.

#2

Can you share the LO file so we can see what is going on? Likely it is too large to upload here. If so, upload it to Drop Box and share the link. If you can’t make it public, send me the link in a private message.

#3

Here is a link to the LO file https://tmsarchitects.sharefile.com/d-s5d4b6b9672f47fc8

#4

SketchUp%20Screenshot

This is what the final rendering should look like when the lines are hidden properly.

#5

Downloading it now.

#6


Also note the junk in the eaves that is more than 30’ behind the eave that really should not be in this image if rendered properly.

#7

Is that last screen shot from a PDF or from LO directly?

#8

LO directly. However, it transfers to the PDF file.

#9

What if you set output quality to High?

#10

Same thing happens. Is there a way to change the output in LO itself or just in the dialogue box when printing?

#11

There’s an Output setting in Document Setup>Paper but it does the same thing as setting the output to High when you export the PDF.

#12

So the horizontal line that runs across the bottom small windows went away when I joined the sloping bit of the way to the vertical face. I cut the group for the sloping bit, pasted it into the group with the vertical wall and exploded it.

IN LO:

In the exported PDF:

The edges that form the seam between the sloped and vertical wall are softened, not hidden. Turn on hidden geometry and you’ll see the dashed line instead of the dotted line.

Softened edges:

Hidden edges:

Unsoften those edges in both groups and hide them instead. You should get the same result as putting the geometry together in a single group. Here’s the result in LayOut after converting those edges from Softened to hidden.

A lot of the trim is showing reversed faces which really should be corrected.

The diagonals in the molding at the right appear to be coming from the extension of the rake trim on the gable. It be trimmed off although it really shouldn’t show. I expect this is an OpenGL issue.
Screenshot%20-%205_16_2019%20%2C%202_20_22%20PM

#13

Thanks! I expected that they would show properly once merged. I will clean up the model a little bit. It was just easier to work with in this group and component format while making a series of complicated changes for the clients. Things get a little out of control when your in a hurry.

Thanks for your insights. I’ll make some modifications so that the construction documents will render correctly.

I have some removed contours in this model that are also showing up as hybrid lines. I will double check weather they are hidden or softened. I can also try isolating them in a group and put them on a layer that is completely hidden.

Again, thanks for your input!

1 Like
#14

Yes indeed.

Happy to be of help if I was.

I have to say the images in the LO file look really nice, unwanted lines not withstanding.

1 Like