How to unhide in my.sketchup

advice

#1

how do I unhide hidden objects,


#2

There isn’t (yet) a user interface command for this. See previous thread:

The short answer is to open a JavaScript Console and enter this command:

And to get a Console window, in Chrome go to Menu (the three bar icon top right) / More Tools/ Developer Tools, then click on the second tab ‘Console’. That works on Mac (certainly) and probably on Windows too.

And @DanRathbun says in the above-referenced thread (referring to Windows, I think):

Most browsers have a JS console.

In Chrome it’s CTRL+SHIFT+i to bring up the Dev Tools window.
In MSIE, it’s F12.


#3

if you want to add a shortcut key toggle that will last for the current session…

this ones for 'hidden geometry and uses K, because H is used for ‘Pan’ for some reason…

document.addEventListener('keydown', function(event) {
    if(event.which === 74){Bindings.RunCommand(Bindings.CommandIds.VIEW_SHOW_HIDDEN)}
  }
)

john


#4

I think you can just use Outliner to get a list of your groups and components, find the one you want and select the UNHIDE option. You might have to right click on the listing first before UNHIDE is available.
Outliner is located in the Trays.


#5

Outliner hasn’t been added to my.sketchup yet.


#6

Outliner is not in my.sketchup [yet].
Even in SketchUp itself, to see it you’ll need to add it into a tray in v2016…


#7

Sorry. Missed the My.SketchUp part.


#8

Bindings.RunCommand(Bindings.CommandIds.EDIT_UNHIDE_ALL)
VM246:1 Uncaught ReferenceError: Bindings is not defined
at :1:1


#9

Well, it’s been some months since I tried my.sketchup. It used to work, now it doesn’t (I just tried it myself), and I’ve no idea why: either why it used to work, or why it now doesn’t. May need a response from the my.sketchup team to explain.


#10

I realize this discussion has been silent for a bit, but getting ready to launch using my.sketchup with students and hide/unhide is pretty critical when working with kid models. Any updates about how to unhide?


#11

You can use the Display window (right side) to toggle on hidden object. Then right click the hidden item and choose Unhide.


#12

Thanks so much! Guess it was too easy :slight_smile: I’m really glad the my.sketchup is available since we are now a chromebook only school!!


#13

Have you had a look at our new “SketchUp for Schools” edition? It was built specifically to support folks like you who are using Chromebooks (and Google’s GSuite for Edu) in an academic environment.

john
.