How to pre-orient groups and components axis?

Is it possible to “pre-orient” the axis of groups/components?
Not always, but often, when creating a group during modelling, the axis of the newly created group/component does not match the axis of the model.

Like when the axis of the model is X,Y and Z. but then the axis of a newly created group seems to be Y,Z and X!?
After manually changing the axis of the groupo, openings in wall get closed and therefor need to re-open the walls to get the windows visible again, also due to the misplaced orientation of the axis within the grouop, i guess.

Why dont these axis match, and is it possible to set the orientation before creation?

When you create a new component or group the axes are oriented parallel to the global axes or the axes of the context in which the component/group is created. When you create a component one of the options presented along with giving the component a name is to set the axes. You can and should set them to suit the object and make inserting it simple. You can also change the axis orientation of both groups and components after they’ve been created, too.

Here’s an example component I made. The component’s origin is place such that I can drop the component in exactly where it needs to go between case and door.


When this component is dragged in from the Components panel it comes in aligned with the model axes and is attached to the cursor by its origin.

Dear DaveR, i’ve noticed the option when creating components, but when this feature is not available when creating groups.

And like i mentioned before, after changing the axis manually after creation other weird things happen, like openings getting closed and need to be opened again to get the group visible.

update: did not record it but just created a group, changed the axis manually, closed the group … and the group was deleted o.0
Talking bout strange things happening ^^

You’re right. With groups you have to go in and edit the axes after making it. Or position the geometry so it is aligned with the model axes before creation.

Modifying the axis orientation in a group should not affect things like openings in the group. I expect you’re doing something else in the process that you shouldn’t be.

Again I think you are doing something else besides modifying the axis orientation. Without seeing what you are working with, though, it’s anybody’s guess what.

Why are you needing to change the axes in a group? This tends to be important for components that are going to be inserted into other models from the Components panel but usually not so much for groups.

Still, find it strange the axis does not match the orientation of the model (to start with).

Tried to capture what happend, but somehow the issue did not occurduring while creatiing the previous groups.

create and edit group wth misaligned axis

Why i want to change orientation?
Cause it irritates me when the arrow keys do not point in the right direction when editting.
You point left? we go down! Wanna go up? we go left! etc.

It may be a smal issue, but many small issues can result in a mayor irritation :wink:

Turn off the distracting sky in the background so we can see the color of the axes. It looks like you’ve created the object so the blue axis points out away from the geometry instead of up like it is supposed to do. did you make the group with the window laying down on the ground plane?

Your comments make it sound as if you think the axis orientation is totally random but it isn’t. It’s entirely predictable. As I wrote, if you do nothing to change the axis orientation they will align with the model axes.

SketchUp has no way to know what it is you are modeling or how it’s supposed to be oriented when in use. You are responsible for that.

My appologies i’m jumping from this to that and in between to get this done before my deadline ends…

Quick capture of the different orientations of axis within this model (without the anoying sky).
sketchup orientation of axis

Sketchup may not know what i want, but if gravity goes down, why change the orientation so the gravity goes to the left? :wink:

So what I see if that you’ve got a different axis alignment in the house group than in your model. Again, as I told you in my first reply, the axis orientation isrrelative to the context you are working in. When you have no component or group open for editing, the axis orientation is based on the orientation of the model axes. When you open the group for editing the axis inference andorientation is based on the group’s axes.

At the beginning of your screen capture you can see that the inference color is following the model axes and when you open the house group it follows the group’s axes. Exactly what it is supposed to do.

Slightly off topic, you would do better to model with the Camera set to Persective instead of Parallel Projection. That would help you see this alignment stuff better.

Another attempt :slight_smile:

i start each building volume with the same component “pand#0”, make it unique and edit it as needed, may rotate it so the front facade faces in the direction of the road. So each building would have the same orientation from its origen.

If needed i add details to some buildingvolumes like windows and doors for our analysis.
As you can see, it does not matter how i rotate the buildingvolume, when i create a group for a window or something inside the buildingvolume component the axis does not care if it is or is not the same as the model or component orientation? In this sample even after rotating the buildingvolume, both windowgroups seem to orient the same direction, so first to the front second to the back, but both do not match either the model or component axis.

sketchup comp 0 unique to next

Not sure how i can further explain the issue with the axis.

When you add the window as you did, SketchUp automatically gives the window component gluing properties which is why the axes are aligned as they are. Again, totally predictable. If you don’t want the window to have the gluing properties, don’t make it inside the house group. Or edit the component in the Components panel and remove the gluing.

Blue pointing out from the wall is what you have to do for gluing/cutting components, but if you’re just making a group inside a group, I would think it adopts the parent group’s axes as @DaveR describes.

(The red-green gluing plane creates it’s own frustrations. With one of those windows, it glues and cuts in ok to a face in an arbitrary location, but if you try to work with a guide line to position it, once you snap to the guide, blue goes up instead of perpendicular to the wall. That makes it a two step process to place the cutting component into the wall: First deliberately in the wrong place, and second move it to the guide line.)

I knew to make blue out on purpose, but didn’t really think about it happening “automatically.”

1 Like

I am aware of the glue options for components, but in groups I couldn’t find where to set those properties.
Thinking about this (out loud), could this be why gaps somehow disappear after changing the axis of the “glued” group, because the gap is set to a specific axis?

Anyway, the best thing would be to change my workflow, which has been working for a long time until … ^^

Not an option for groups but if you are going to reuse the thing elsewhere in the model, it would be smarter to make it a component in the first place so you can bring in copies from the Componnents panel.

Tested all evening with those groups and I suspect that switching to components would be the best choice, even if it was for a unique group. adjusting the group’s axis continues to remove the associated gaps.

PS in reply to the camera settings, i switch a lot between them so it could have been it was set to parallel during capturing. will try to remember to switch back to projection before i start the capture.

This is not what I see. It makes no difference whether creating the group on an arbitrary location on a face or using a guide in plane of the face to snap to. As long as the group’s shape is (like previous case with no guide) inside the boundaries of the face. Local blue will be perpendicular to the larger face.

For now I can only see consistency in how new groups and components get their own local axes upon creating them.

1 Like

Hmm, when did that get fixed? I’ve only been on 2022 for about 6~8 months. I tried it now, and sure enough it’s well behaved. It didn’t used to be.

I don’t know.
I’m still trying to figure out where the local origin will be located and in which direction (although in plane of the larger face) red and green will run. I mean what general rule.
For orthogonal faces one can predict the rule. But on rotated faces with “weird” drawing axes it’s a different story.

There are some funny differences (benefits?) for groups over components when creating them.
They can both cut openings but groups don’t suffer from Z-fighting.

basic groups on face.skp (141.6 KB)

It seems that the orientation of groups is always such that the (blue) Z-axis is perpendicular to the plane you are drawing on. When the group cuts an opening, it is somehow fixed to the group’s X-axis(?) so if you change the axis within the group, the opening will disappear and you need to redraw and cut the opening to get the group visible again.

The whole consept of cutting an opening is pretty much the same for groups components.

  • Local blue needs to be perpendicular to the face the object sits on.
  • red and green need to be IN plane with that face

So whatever you do the local axes, their origin should stay in the plane of the face and blue perpendicular.
Changes to the object’s geometry do not affect the “glue to” ( ->and cut opening) properties. Only the local axes changes may affect if you mess up with the two rules mentioned above.

Why would you do otherwise?

Why would you want to?