How to export solid filled hatches from a Layout Viewport to DWG

I’ve been using this method to be able to have a direct way of producing hatches in my Layout DWG exports.

This is the closest I get into a standard CAD output that other people can use and I’ve been asked to share the process with another user. I thought it would be better to share it with everyone, hoping it might help.

So here it goes…

The following is an example of a model where hatches have been stripped down to color fills (leftmost viewports), so they can export as vector solid fills to CAD.

Unfortunately, you’d still have to fix the DWG’s model space as stacked viewports are everywhere:

Alternatively you could use the Export for Sketchup method, which will stack everything up in model space, but that is rather difficult to use for other people if they want to edit the drawing. So interior designers, landscape architects and even structural engineers, to name a few, might need the standard export method and as, most probably, you will have to use stacked viewports, be ready for having to fix this part.

You have to be careful as if vector viewports produce loops or holes in hatches, these will fail to create the hatch. You can see that happening in the section in the bottom left. As long as you avoid those, you should be fine.

For Layout export to produce solid fills, you’ll have to combine the following:

  • Sketchup style should feature shaded faces (no textures);
  • Layout viewport should be vector.

You should only use this combination in your stacked section view. Be very careful to use it in your background as it will export all faces as an hatch, into DWG. For instance, if you have a terrain, full of triangles, each triangle will be exported as a single hatch and your DWG file will probably be unworkable.

I still use hybrid rendered viewport in background for clients and contractors.

For permits the background must feature hidden line or flat shaded (all same) Sketchup styles, so that all is vector and municipalities accept my DWF output in an “easier” way.

In my country this will still result in a non standard export. This happens because Layer info for construction elements is not being exported. This Layer info exists in the Sketchup model, as Sketchup Tags, but Layout isn’t able to read tags and output them as CAD layers. No CAD layers, no DWF layers…

This should really be fixed.

You can find the model, layout file and DWG export attached in the bottom.
House Example.skp (185.9 KB)
House Example.layout (1.1 MB)

House Example.dwg (22.5 KB)


Hi! Thank you for sharing your workflow!

I have two questions:

  1. why do you use empty scenes for hatches?

  2. If I select “Export for Sketchup” in Layout DWG export settings, no solid hatches seem to appear in AutoCAD. Is this normal?


Those aren’t empty. I forgot about those. I’ve used Curic Section to create the section cut face. I shouldn’t have.

@curic4su should take a look at this.

Curic Section creates the section cut face and assigns it to a Layer.

The section scenes feature that layer exclusively, so they are supposed to show the section cut face exclusively.

However, Curic enforces those section cut faces to be hidden in all other scenes, except the scene used to create them.

So, Curic is making it impossible to isolate the section cut face and destroys the process I tried to show you.

If using this process, what you have to do is forget about Curic Section and use Section Cut Face plugin instead. Maybe Skalp allows it too, I don’t know.

I will recreate the process in a new file and replace the Sketchup model above, in order to fix it.

There is a way to isolate just the sections using Curic Section… which @curic4su could build in fairly easily.

Make your Curic Section cut, select all → hide → update scene. Since the Curic Section is locked, everything else hides except the locked section. If you want to change the section fill or update the section settings, you just have to view hidden objects → select all → unhide first, then clicking the scene button again takes you back to just the isolated Curic Section.


It is sort of like a Donley Section mashed up with Curic Section… a Donley Curic Section

1 Like

It’s interesting that those section do not display in Sketchup but they do in Layout … :slight_smile:

What about number 2 using “Export for Sketchup” does it work for you?

It works in Layout because Layout doesn’t understand what’s happening behind the scenes with Sketchup and Curic. If you work continuously in Sketchup and send to Layout all looks good. This was what happened to me.

But as soon as you close the file and open it again, all Curic’s settings get applied and the isolated section scenes get messed again. This was what happened when you opened the file yourself.

The file stored in Layout is fine, because it is still as it was inserted.

At least this is what it looks like.

I will try your method, but I’m not sure it works if you close the file and reopen it, or if you update the section using Curic’s plugin. The issue might persist after the update or after a file open as curic on those occasions seems to enforce the original settings.

It’s a huge nuisance and it is the main block for me to use Curic Section at full speed, along with the needed but dreaded stacked viewports.

I will also check what’s the workaround we are using at the office as it’s not me that deals with this process at the moment.

I’m updating the 3 files and added some colors to the hatches, just for clarity, as this is exactly what we are doing now.

The old files done with Curic Section, which present the error in Scenes with isolated sections, will be here:

House Example.skp (266.1 KB)
House Example.layout (886.3 KB)
House Example.dwg (21.8 KB)

1 Like

It works, but people that want to carry on editing the exported DWG will have a hard time doing it.

Export for Sketchup creates a group for each Layer you have in Layout. If you open the DWG it will be a mess for working in CAD. Eventually you’ll want to explode the groups that you find in CAD. However when you do that, every object will fall into Layer0. As anyone that used CAD knows, a drawing organization is based on Layers. If all is Layer0, you won’t be able to work.

Export for Sketchup is good, sometimes, for some consultant’s work. But they will roll their eyes nonetheless.

It’s amazing how there isn’t a Layout DWG export method that is exactly the same as Export for Sketchup but, instead of grouping by layer, it should simply assign layers to objects and leave them ungrouped.

I understand what you mean, but this poses other problems:

  • We need two scenes of the model to stack - one is the background with full view of the model; the other is the section cut face itself;
  • If we hide the model in one scene we can’t generate a section. We would have to unhide the model, then generate the section, then hide it again.
  • If we hide the model in the isolated section scene as soon as we regenerate that section from the model in the original scene, the current scene’s section will become hidden (which is actually the original problem).

I think we have another method, but I have to check. I think it is a matter of simply turning on the right layers on the right scenes, when we have to, before sending to Layout for a final output.

It’s stupid and tedious, but it’s the only way to have an effective scene to create our stacked viewport, from Curic Section.

There is a point where we actually start working on section details, where the original curic section isn’t the one we stack anymore. We still generate the view of the model using curic, but the stacked section scene is the one we are designing manually, so it ceases to be updated by the plugin. At that point we are on construction documentation though, and that’s when the models start to change based on our work with section cut faces and all the details we have to add to them.

The stages where Curic should act better are on permits and on the stages where the project is being detailed in 3D for construction and dealing with engineers. On this stages we are still dealing with a level of detail where modeling the material layers in Sketchup makes sense.

I’ve been using it across several projects for a couple weeks now, and there are no issues when you close/reopen file.

Correct, the default settings are for Curic Section to only work on unhidden objects. So if you try to update the Curic Section when everything is hidden, the isolated section disappears. But you can either leave the default settings as they are, and unhide hidden objects first, or change the default settings to apply the Curic Section to hidden objects.


1 Like

In SU, Hidden Objects can be customized per scene - hiding objects in one scene doesn’t transfer to the other scene.

1 Like

Correct, you would have an isolated section viewport on top of a background viewport. In LO, I’ll even go so far as to put a semi-transparent white layer between the two to make the isolated section pop and fade the background (while Curic Section can do this with the Clipping feature, the transparency of the SU clipping face affects LO rendering in hybrid/vector for objects behind the transparent face). All these steps to make the perfect section sandwich… which of course is more complicated than it should be, but I like the way it looks.

1 Like

Exactly! I was just looking at Curic Section settings, after reading your post, because I had the idea my eyes had crossed this setting.

The problem I see with this approach is if users are relying on hidden objects properties to hide objects they don’t want to be sectioned.

This might happen on different project versions, in example.



That’s really it.

Curic should allow a single section to be reused in other scenes:

  • We might use the section in reflected ceiling plans;
  • As stacked viewports;
  • As different styled scenes that use the same section;
  • As scenes that display several versions of the interior decoration…

There might exist many other scenarios. I hope he sees this post.

The best way to fix this Curic issue…

I just remembered the workaround we use to circumvent this Curic issue. We deal with Sketchup Tags and Styles in Layout viewport:

  1. We insert the Section Scene with the Curic Section in Layout.
  2. We duplicate the viwport distributing both into 2 Layout layers (background and section)
  3. In the background viewport we apply a Sketchup Style which has a white auto Sketchup Section Fill turned on. This hides away the section made by Curic. We could also hide the layer but it’s not needed and I don’t think having it on impacts viewport regen speed.
  4. In the stacked Section viewport, we hide the model’s tag and change the model style to the one featuring Shaded faces (without textures).

Layout allows the two stacked viewports to be used from a single scene.

This is simpler than your method, I believe.

Anyway, your help and attention to the post, is really appreciated.

1 Like

Strange, because I don’t get any solid fills expored over to DWG when I use “Export for Sketchup”. Can you show a screenshot of your export options?

Sorry. I didn’t test it. I seldomly use Export for Sketchup anymore. I will test it and report back.

EDIT: It’s not working. I erased the background images and got no hatches: