How to eliminate contour lines easily


#1

Hello,

Another frustrated Sketchup user. I recently tried creating CONTOURS for the first time, but neglected to expand the elevations BEFORE creating the contours. Unfortunately I didn’t create a separate layer for the contours so I “baked-in” the contours and saved my work before retiring for the evening. Now I am unable to UNDO the contours, expand the elevations in my landscape and then create Contours properly. I can click on separate parts of my landscape and it seems as though I should be able to expand these sections, but the Push/Pull tool won’t work. I get the banner “Cannot Push/Pull Smooth Surfaces” PLEASE, can anyone tell me how to UNDO CONTOURS?


#2

Not sure exactly what you are seeing, but I am sure we can figure a way to work it out. Any chance you can share your file? Then we can see what you are looking at a get you a solution!


#3

Wow, that was fast! I just signed up for the Sketchup Community, so bare with me. I will share the file with you if you tell me how to do that. Thanks.

Drew


#4

Click reply, then the Upload icon above the text box.


#5

KW CONTOUR 1~.skp (1.5 MB)

Hi Aaron,
Here’s the file (hopefully) Think I figured it out. Sorry, it’s a bit of a mess. I don’t use Sketchup very often and thought I’d try and 3D model a property I’ve been looking at. Let me know what you think.
I essentially traced the contour map of a JPEG of the property and then tried to create a 3D contour map from it with Sketchup. I later realized I should have expanded the elevations myself BEFORE creating contours from the Sandbox. Now I’m left with a mess of contours without elevations and I’m now unable to expand the sections of traced contours to create the elevations I want. Have a gander and let me know if anything can be done. At this point it seems like all I can do is show “Hidden Geometry” and manually erase all those bloody contour lines.


#6

Slightly messy model. I would just delete all the surfaces and isolate each line and move them to the correct elevation then just repeat the sandbox.


#7

I know, it is messy. As I said earlier, I really only use Sketchup perhaps a few times a year.
By “surfaces”, do you mean Erase the contour lines, manually, as I described? There must be an easier way to just UNDO Contours. Please advise. Thanks.

Drew


#8

So I just exploded the model and deleted the surfaces.

Next step would be to move each line to the correct elevation then use the sandbox tool.


#9

Would you be able to share me the .skp file please? I’m not sure what to do with a JPEG other than re-trace it. Also, I would prefer to keep the border around the lines. I’m sending you another version. In it, you’ll notice that you are able to click on different sections of elevations, but it’s not possible to expand these sections.KW CONTOUR 3.skp (1.5 MB)


#10

Is this what you are trying to do:


#11

Something like that, though it’s a bit hard to see. Though, I would like to get a handle on how to do it properly, myself. My frustration certainly has to do with my limited knowledge of the program but also, the fact that I was able to create Contours ( though improperly) and then not be able to simply, intuitively delete/undo them is…well…frustrating to say the least.

I’m assuming that you made the model a “Group” or Component and then Exploded it. As it’s not obvious to me, how then, did you DELETE the surfaces so quickly? (obviously you didn’t manually Erase them all)
My initial thought was to just push/pull the connected elevations to the proper height and then go the Sandbox and do the contours, rather than pulling each line up. Thoughts?


#12

When sandbox creates surfaces, they are a series of triangles with the edges softened, so they cannot be push/pulled.

The (more) proper way to attack it would be to draw the lines and move them vertically, THEN create the surface with Sandbox.


#13

I actually did delete the surfaces manually. The model had two random groups that I assume were created by the sandbox tool. I exploded the groups and selected the surface faces and just deleted them.

If you want a smooth topo model than you don’t need to extrude the model. In fact it makes it much more difficult to deal with in the long run. If you want to generate a stepped topo model, you wouldn’t want to use the sandbox tools. Either one or the other.

NEW KW CONTOUR 1~.skp (2.8 MB)


#14

Here’s a Skill Builder that walks through the process… assumption is that the lines are at the proper height before you run Sandbox.


#15

Yikes! You’re braver than I…and you probably have a Stylus/Pen. Doing it with a mouse is a pain.
It really seems to me that there should be an easier way of eliminating all those Contours WITHOUT having to manually Erase them… I mean, it was easy enough to CREATE them (albeit improperly) but the fact that they can’t be “Undone” other than by saving earlier versions of the file (without having improperly created the Contours using Sandbox) is pretty frustrating.
That said. Thanks so much for the help all the same.
Now I have to download a later version of Sketchup to see what you’ve done with it. I haven’t downloaded the latest version because the last time I upgraded, I had to reconfigure my Logitech Mouse all over again. I’m hoping I don’t have to do that this time.

Cheers

Drew


#16

Took maybe 2 minutes with a mouse. Its not too daunting if you know what you are doing.

Also SketchUp 2016 is the best version so far in my opinion (especially in terms of organization).


#17

Actually, the surface that is created via sandbox is a separate group from your initial lines. I am guessing that, at some point, you exploded that group and it merged with the original lines.


#18

Aha! You’re probably right. Not being a regular user of Sketchup, my modelling practices are, evidently, not as clean and precise as they could be. I’ve used it so infrequently these past 3-4 years, that I have to remind myself just to use Layers, instead of relying on individual components solely. I’ll be sure to improve my practices now that I have the 2016 version.

One question about that: Is there any way of importing my preferences from the 2014 version of Sketchup I’ve been using, as well as the settings from my mouse? Last time I upgraded I had to reconfigure everything all over again. It doesn’t take that long, but it is a pain to have to do it every time there is an upgrade. Please let me know.

Drew


#19

Yep! Check out this article.