How to cut out the top of this part


#1

Hi,

I have this object STL http://quemfazsite.com.br/temp/Tripod_Hub_v3.stl

I want to cut the top and bottom of it. See the arrows

I tried creating a long tall box in the top and another in the bottom and tried subtracting it from the original object but a message saying that my original object isnt a solid appears. I tried the plugin SOLID INSPECTOR 1 and also version 2 but not success.

So my question is this: how can I deal with these STL objects that I frequently download online? Most of them look corrupted, isnt there an easy way to make skecthip understand these objects better so it becomes easier to deal with them?


#2

Try importing to a larger scale than the original (use, for instance, Meters instead of Millimeters as the import unit), and then scale the imported part back to its original size. That would reduce the amount of missing small faces.

Anssi


#3

You have the free version of SU and therefore limited options of formats you can use to download a editable model you can use in SU. More than likely you will have to import a format SU can import and open, your version does not have solid tools so you will have to create a work flow to get there. Check out digital asset exchange ( DAE) which is in the KMZ format you can import.


#4

If you want to just cut hub flush, use section cut plane, then context click to create group of that cut, then you can delete the top of hub w/o destroying the model. The hub does not go thru so don’t know what you want to do with bottom. In stead of section plane you can also just select top and move down making sure you use the z axis as direction inference.


#5

I have the pro version, I have access to solid tools. Anyway, I only have access to the STL format of that part, when I import it into my sketchup problems arise. The dimensions is not a problem, I did that with meters and still got problems.


#6

For as simple as that part is, it would be easier to forget the STL and draw it from scratch. More work to clean up the garbage than draw a clean model from the beginning.


#7

Change your profile it states the free version, I exported in meters and got model as you show but in mm it is just a big sphere. Here is pic form SU after importing it via dae format, since it is a su model the edit should be easier or you can now also open in mesh lab which is gives you many options on how you filter, decimate, interpolate mesh,dot…dot…dot


#8

I tried it now and I didnt understand. HOw can I convert it to meters? It is in milimmeter, how do I convert it to meters to work on and how do I later convert it back to millimeters?


#9

Go to widows, model info and drop down shows a units, suggest you use decimal vs fraction, you can set accuracy ( display accuracy I usually use 3 decimal).
When you first use the stl import in SU there should be a flash screen and it gives options of mm or meters that is where I selected meters. The stl format is usually non dimensional but author included the dimensional options. Once you finish your model and to rescale draw a line of known length, use tape measure tool to measuer it then enter the desired scale. ( Read help center info first) The program will ask if you what to scale, answer yes.
I used you stl model, imported to su, then exported as dae. I then used the MeshLab program ( it has a number of filters one can use clean and repair, re-mesh et., and then inported back to SU . I would not suggest you do that step just because of learning curve. Do not do repeated import / export of the basic stl it can get bloated etc. Use the dae to import back to SU and use that for your edits.
In the future make max use of components they isolate geometry to prevent it form sticking to one another. So like the screws all you need is 1 component, make hub one also. Reading help would be help also.
I assume you will plan on print this. If so there are requirements also. It will need to be a solid model.
When you get to that point suggest you make new post you will probably need more help.


#10

This topic was automatically closed after 91 days. New replies are no longer allowed.