How to curve a staircase to a specific radius?

Dear SketchUppers, I’m trying to use Fredo’s ‘Radial Bend’ from the FredoScale plugin to curve my staircase. The bending is done superbly, compared to Shape Bender, but I’m having a problem with the radius.

Is there any way to specify the bending radius in FredoScale?
Thanks in advance

1 Like

Btw, here’s the same, done with Shape Bender. Although I can bend it to a desired radius, the geometry is exploded inside, so my railings, stairs and balusters are all one single geometry and it’s quite messy compared to Fredo’s.

No. You can’ specify the radius. In Shape Bender the thing getting bent gets stretcher or shortened to match the length of the curve. With Fredo6’s Radial Bend, you would need to make the straight run of steps the same length as the length of the arc with the desired radius to get that radius in the bent curved staircase. In your case you would also start at the bottom left corner of your stairs with the bending.

1 Like

Thanks for the quick reply as always Dave. :slight_smile: I see why it can’t be done.
Do you perhaps know of any other plugins that might be helpful in this situation, that I could try out?

1 Like

All of the other extensions I can think of will do basically the same as radial bend which means the radius is the by-product of the length of the object being bent and the angle of the bend. Shape Bender is kind of odd because it does modify the length of the bent thing to match the length of the curve. The probably with your stairs and Shape Bender is the the depth of the treads and the shapes of the balusters won’t be right if the thing gets stretched of shrunk.

1 Like

Have you considered using Component Stringer.


I downloaded the plugin to give it a try but it seems it’s not working. I have 1 component and 1 vertical line but when I preselect them and click on the plugin name to start it, nothing happens.

Divide the vertical line by the number of stairs.

Still not working Box. :thinking: That’s odd. Is the last version of the plugin 1.3.1?

Make your component and set the axis at the point of rotation.
Create an edge for the height, divide that edge by the number of stairs, weld those edges back together.
Select only the component and the welded edge.
Run plugin.

1 Like

Version 1.3.1 works fine in SU2019.

Here are the basics for a 12 stair 180 rotation.

1 Like

Ok, this is really weird. I’ve never had technical problems I couldn’t solve. :roll_eyes: I’m doing everything exactly as you say Box, still nothing happens.

  • Moved the component axis to the base of the vertical line, point of rotation.
  • Divided the line to 24 segments and welded back together with Smustard.
  • Selected only those 2 and clicked on the plugin.

Nothing happens… Something must be wrong with my plugin, or I need sleep.

attach the model.

VP - Component Stringer Problem.skp (48.9 KB)

There you go. Thanks a bunch for having a look. Appreciate your time. :pray:

I see the problem, you move the axis rather than changing the component axis.
Right click on the component and select Change Axes.
If that doesn’t fix it I’ll look at your model.

1 Like

Oh ok. I already left the PC (3 am here) but I will try again tomorrow and let you know. Thank you so much!

I opened your model and it worked first time for me. Don’t know what to tell you.

1 Like

I got this on his model.

You didn’t click yes to reverse.