How to correct cut opening?


#1

I try to cut opening into plane. The opening should be in the top of the crater.

I cannot find out why my crater does not cut opening into the plane.test.skp (270.0 KB)

I am not sure if do I need a plane at top of the crater to create “window”?

Note I have already learned how to do openings but here I cannot find the problem.


#2

Your crater is a component. As a result, its edges are isolated from the model context and will not cut the face (which is in the model context). If you select the crater without opening it for edit and then do Intersect Faces With…Model, the new edges created will be in the model context, will cut the plane face and then you can erase the portion inside the intersection.


#3

the problem is you haven’t set ‘cut opening’ or ‘glue to horizontal’ like shown the gif in your duplicate thread,

don’t double post carry on in the other thread…

john


#4

I selected “cut opening” and “any” which should be the same. Anyway I can explode it and select “horizontal” and then after fixing axis orientation, this is the same result, no opening.Crater big - deep.skp (285.7 KB)


#5

you did some thing wrong…

john


#6

That is strange. I have set it Cut openpenning and both axes I have tried any and horizontal. I have SU8 so I cannot edit it like you do.

EDIT:
Mistake. I see the same menu there. I did not know about it.


#7

When I open you first model, the crater component has Glue To Any set, but Cut Opening is not checked. If I make the cut opening setting, delete the existing instance and pull a new instance from the components window, it cuts the plane exactly as required.

There are some subtle details (some might call them flaws) in how these so-called behaviors work. Glue to must be set to something other than “none” and the Cut Opening box must be checked in the Component Edit panel before an instance of the component is placed. Editing these behavior properties will not retroactively change existing instances. Copying an existing instance that is glued and cuts an opening will create another instance that also does, but copying an existing instance that has been unglued (or wasn’t glued in the first place) will not activate glue to or cut opening on the new instance.


#8

It really works from the Component Windows, select, and then edit. I wonder why, there is difference.

Thank you. Now I will double check with the Edit menu in window Component after I select it.

Edit:
For me solution is the post with animation which shows the existence of Edit menu in Components and second possible way how to do it or how to check opening state.


#9

New problem. I repeated all the steps, double checked the cut opening here:

test.skp (1.4 MB)

The component “protitankový příkop jednostranný 1” should cut opening. But does not.


#10

I solved this when I changed opening from horizontal to any.

But new problem in original file: in one case when I paste the working “cutting” model so it does not work.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.