How to config RubyMine debug?

Can somebody help me ?

The picture for setting ruby remote debug is as follows
1)“Program” Can the content be set to ruby.exe or ruby?
2) “Arguments” Can the content be set to relative directory+ debug-sketchup.rb 18 or absolute directory + debug-sketchup.rb 18?
3)“working directory” Infer to the directory of ruby.exe or sketchup.exe?

Trimble has a RubyMine setup tutorial here …

https://github.com/SketchUp/sketchup-ruby-api-tutorials/wiki/RubyMine-Debugger-Setup

Tried my times. The events still existed.111 22222122

Are you using the SketchUp API stubs ?

I have installed the Testup-2 files according to https://github.com/SketchUp/testup-2
The picture is as follows:
21

I can use Rubymine and RUBY SDK to run and debug common Ruby files.

When using Rubymine with SU debug, the simplest ruby code, for example:
put “hello”
can’t be run and debug.
The hint is the same " Limited Debugging Info: Please select relevant remote Ruby SDK for full debugging info"
???

That was just an example project.


Install the SketchUp Ruby API stubs per …

https://github.com/SketchUp/sketchup-ruby-api-tutorials/wiki/RubyMine-Project-Setup

Every procedure I have followed with the https://github.com/SketchUp/sketchup-ruby-api-tutorials/wiki/RubyMine-Project-Setup

What’s the means for “Limited Debugging Info: Please select relevant remote Ruby SDK for full debugging info” Does the " remote ruby SDK" refer to ruby.exe?

Are you using SketchUp 2018 or SketchUp 2019?

SketchUp 2018 ships with Ruby 2.2. You don’t want to mix SDK and debugger DLLs versions.

1 Like

Thanks for share the valuable steps to me. Such a great answer to us.

Yes. I am using 2018. How to deal with the config problem of SU with rubymine?

I am really puzzled by this.

In your original post it looks like you are setting up local debugging? Is that what you are doing?

Or have you set up remote debugging like our tutorial?

Looks like I’m facing the same problem now.
I think I had done everything in that tutorial.
And when I click debug.
“Limited Debugging Info …” show up.
However SketchUp did open, but i don’t know what to do know.
I just staring at a empty SketchUp windows and nothing happen.
Someone please help me. Sincerely appreciate

I also wathc this tutorial.


but something wrong here.

In the debugger variable. it said “connected”
So i think Rubymine successfully connect the SketchUp.
But I can’t not step through code. even if i set break point.
And I also don’t know how to “Switch to SketchUp and exercise your extension.”

Here’s what I see when I start debugging.

Maybe you could try vscode to debug SU.

I tried vscode first.
But fail too.
Do you make it to debug SU on vscode?

Discussion of VSCode Debugging is offtopic for this thread.
Please take this discussion to one of the other topic threads …
https://forums.sketchup.com/search?q=vscode%20debug%20category%3A13

@jack233924 FYI, Posting the same issue in multiple topic threads is contrary to tidy forum rules.

I’ve answered this in your other topic …

Nothing happened when I try to debug in Sketchup by Rubymine

1 Like

Yes, example setup can be found here: https://github.com/SketchUp/sketchup-extension-vscode-project

1 Like