How do I retain imported texture names?

How do I stop Sketchup renaming every single imported texture a variation on ‘auto’ and how do I retain their original names?

I put plenty of models through and I can’t have them all with the same name. It takes ages manually reapplying the texture names before export.

Presumably there’s a setting I’m missing?

What version of SketchUp are you actually using? What operating system? What graphics card? Please fix your profile.

What textures are you importing and exactly how are you importing them?

2020 pro. 1070 Maxq.

This happens with every single model I import with every single texture. It has never, ever not happened. The format doesn’t matter, either texture or 3D file. It always shows up as ‘auto’.

This is with universal importer and importing normally.

I have to go through every single texture and rename it before export. This can take 20-30 minutes sometimes.

I presume there’s a box I need to tick. No idea what it is.

What is the original file type you are importing? You might check with the author of Universal Import to see why their importer is changing the names.

Why does your profile say you are using the free web version?
Screenshot - 2_25_2021 , 9_11_43 PM

Like I said, this happens importing everything, plugin or not. All textures types. All model types.

All of them have texture names with variations on ‘auto’.

I’m only trying to help you. I’ve never had any materials get new names in imported files in any version of SketchUp. There must be something different.

I recall another post about <auto> material texture [re]naming…
I don’t think it was ever fully resolved, but it was something to do with a rendering extension causing this behavior.
Do you have any rendering extensions installed ?
If so please disable them with the Extension Manager and restart SketchUp…
Any change to the material texture naming ??
If so please report back with details of the probable culprit - it would be good to resolve this issue…

1 Like