How can you stop Sketchup from creating unique # components

AFAIK each instance of a DC becomes unique when inserted, unless it is just a copy of a component already in the model.

As soon as you change any of its parameters it becomes a unique component and adds a hash/number suffix.

If I import one sample DC [this is using SU 2021, but I think it’s the same in any recent earlier version], then make a copy with Move/Copy, or Edit/Copy then Edit/Paste, there’s still only one component definition in the Component Browser.

If I drag another copy out of the Component Browser, that too remains just another instance of the same component. But as soon as I change any of its component options, it become unique.

[Gorgeous looking model, by the way!]

PS. If you only have a few different instances of your DC, you can Save As… your model to v6 of SU, and reopen it - that old a version of SU didn’t have DCs so they are saved without the DC attributes. That will reduce your file size a little. Or there’s a plugin to do the same, from Eneroth3, on the Extension Warehouse. Something like de-dc-ify I think. [Yes, that finds it: Search | SketchUp Extension Warehouse]

1 Like