How can we import a KMZ file from google earth successfully

sketchup
#1

We have tried several times and don’t succeed once.

#2

A .kmz file is actually a zip archive that can contain several kinds of geometric data files. The important ones for your issue are .kml (Keyhole Markup Language) and .dae (Collada). Google Earth desktop version can import a .kmz containing geolocated .dae and can export a .kmz containing .kml, but so far as I know cannot create .dae. Sketchup can export and import .kmz containing geolocated .dae, but cannot export or import .kml.

This one-way relationship was all Google needed for their envisioned use of SketchUp to let users create 3D buildings for import to GE. When they found other ways to create 3D buildings, Google sold SketchUp to Trimble and after 5 years the arrangement to import terrain and images from Google to SketchUp expired, forcing Trimble to find an alternative source.

There have been a couple of (unpublished) attempts to write an extension to import .kml data into SketchUp (including one of mine). For technical reasons I won’t belabor here, none of them has been or will ever be 100% successful. My version has been adequate for a couple of SketchUp users, though. PM me if you’d like to give it a try.

1 Like
#3

Many thanks for your clear and detail reply . Where can we find the extension just mentioned above?

#4

Check your private messages (click your avatar icon at the top right of the page).

#5

Unzip the kmz and see if there’s any geometry in it. Google doesn’t allow scraping their data and modifying it, so if you’re trying to scrape terrain or buildings, forget it, or go read the terms of service.

If it’s a legitimate usage of kmz, you can get the geolocation from the unzipped kmz (now just a kml or keyhole metalanguage file), and see the associated geometry in collada (.dae that’s just geometry xml). This does not sound legit though - please see Google’s terms of service.

#6

I’m new to sketchup. I made a multipatch layer in ArcMap and exported it to a kmz file. I tried to import it into sketchup and it said import failed. There is geometry in this file since it was made from a geometric 3D object. What is wrong?

#7

Most likely the geometry is kml data, not dae. Please read the earlier posts in this topic.

1 Like