Hiding group intersection lines (without a solid object)

modeling

#1

Happy Friday everyone,

I have a question regarding the intersection of lines of two groups (and haven’t seen an answer in the forum that solves what I need exactly). I wonder if there is a way to make a surface (of no thickness) opaque or given visual priority so to speak so that the lines of a group touching it do no show through.

An example to clarify:

I have a cable tray sitting flush on top of a stone. The stone is 40 mm thick. Both are made as separate groups. The cable tray is solid and has a flat bottom and sides but an open top. In reality the aluminium faces are about 2 mm thick but I wanted to minimize the number of lines showing for top views so I am leaving each face without thickness. In reality you cannot see the stone below it of course but in Sketchup the lines of the stones are showing through the bottom of the cable tray because they are touching.

Is there any way to force the cable tray to appear solid and show nothing through it? The workarounds of making the cable tray surface thick, raising the cable tray a few mm so they aren’t touching, or manually hiding the required portion of the stones’ lines are possible but all cause other difficulties. Making the cable tray surface thick is probably the simplest of the three but the lines still show at some angles unless you make it thicker than a few mm. I’ve added some photos to illustrate my point (1-current view, 2-cable tray bottom made grey to show better, 3-desired outcome):

Any help is greatly appreciated, thanks!


#2

What problems (or how much of a problem) would be caused by giving the cable trays some thickness, which would be a real world parameter?

You may have heard the term “Z fighting” which is 2 surfaces occupying the same space not just lines (I believe it occurs in all 3D software) - there may be other info in the forum using that search term.


#3

That’s a limitation of your graphics card’s OpenGL implementation. As the camera moves farther away from the model, the top face in the tray and the edges on the block underneath are proportionately closer to the same distance. At some point the graphics card calls them the same distance and shows both of them.

Certainly making the tray without any thickness will result in the edges of the block being shown no matter what distance the camera is at. You should give the tray real world dimensions.

You could divide the edges of the block and hide the edges that fall underneath the tray.

FWIW, I’ve drawn a tray with the bottom and sides at 2mm thick. when I zoom way back, the edges of the block underneath start to show through.

However they don’t show in an image export.


#4

Indeed that is a handy “feature” - the higher you make the resolution of the 2D image export, the more finely will the exporter be able to discriminate between very close entities. If a large exported image file (say 6000x4000 pixels) is awkward to use, the exported image could be scaled down using some other software and still retain the close-entity discrimination.


#5

FWIW, the exported JPG was done at screen size. You’re right, scaling up would probably improve it.


#6

Just a few days ago, I was trying to make an image that would not reveal some edges which were on the far side of a solid that was 0.01 inch (quarter of a mm) thick, at least until the camera was pulled away more than ten feet or so. A 4K exported image showed a lot of ghostly edges, whereas a 5K exported image worked cleanly.

However, I eventually decided to soften all the edges of the rear component that were in contact with that 0.01-inch thick solid, making them invisible from all distances. :slight_smile:


#7

As a simple workaround, the trays could be given a 2mm thickness and the inner edges hidden (as long as your model can handle the extra geometry).


#8

May not be the look you want but you turn the edges off in styles and t urn on use sun for shading?