Geolocation maximum zoom not as detailed as Google Maps


#1

Hi guys, I’m new here. Please be gentle if I’m asking stupid questions but I’m still working my way around Sketchup.

I’ve noticed that the image available on maximum zoom on Google Maps is SIGNIFICANTLY more detailed than the maximum zoom on Sketchup. Heck on the Google Maps view, I can almost count the roof tiles. Is there any reason for that?

Windows/Preferences/OpenGL has all three options (hardware acceleration, etc) ticked and it doesn’t seem to help.

And when I grab a small portion of the image, it’s consistent with the image sketchup displayed in the Geolocation field. I’d hoped that a ‘smaller’ grab would zoom in and get me a better quality image, but sadly it was not the case.

Nuts, new users can only post 1 image so I can’t post the others as a comparison.

Help?


#2

I don’t have a definite answer, but here are some thoughts…

The selector view in SketchUp is displayed using a browser window, so until you actually import the image into a model SketchUp’s OpenGL settings are completely irrelevant. And even then an image is managed as a pixel array so I wouldn’t expect things like hardware acceleration and anti-aliasing to have any effect.

Did you check the date on the two cases - SketchUp’s view vs Google Maps? Google Maps often has multiple images of the same location on different dates and from different satellites, and they can vary widely in quality. If you explore the available dates in Google Maps you may find one that matches what SketchUp gets.

With both SketchUp and Google Maps, if you zoom beyond a certain size you reach a point where one pixel in the original image spans more than one pixel on your display. At that point there is no more detail to reveal. The software will interpolate to fill pixels on your display, but the result will just be a bigger blurry image, not a crisper one.


#3

Good question. My guess is that we’re limited by the maps API, but I’ll check.


#4

That would be awesome. Great support. Needless to say, the more one can zoom in, the more one can construct accurate models using the image as a base. I worked around the problem by using the ‘snipping’ tool that comes with Windows and saving the image from Google maps as .png. Then importing the png into Sketchup and tinkering with the size of the image to get the scale right.

Cumbersome.


#5

Maps API limitation. Just make sure you don’t violate and are aware of https://www.google.com/intl/en_us/help/terms_maps.html


Capturing better Google Earth data?