"Flattening" a split face


#1

I have somehow added some edges into a previously flat face:

The gable of the house used to not have those lines going across it, but I think some movement or perhaps errant selection of edges has caused these lines to appear.

I have since made more changes, so I can’t simply undo to find the cause.

How can I “flatten” these? If I delete an edge, the entire face disappears.


#2

add the skp…

I suspect you moved the one bottom edge at connects the two ‘gable end’ faces, as they both have auto folding…

john


#3

Here you go:

chadwell-house-render.zip (1.4 MB)

There are actually a number of these (you can see another in the background of the original screenshot, also some of the plinths have the same issue) so if there’s a general approach I can take it would be good to know.


#4

I can’t look at your model, but from your screenshot and description it sounds like you may have moved the terrain, therefore twisting the building.
This depends on whether you have grouped things or if it is all edges and faces?


#5

Hmmm. Ok. Didn’t even realise you could move the terrain!

The original design was done for me, I’m editing it. The house in one component, and then inside that it’s edges and faces.

Why couldn’t you see the model - did it upload incorrectly?


#6

I’m on a phone.


#7

Anybody have any ideas about this? Is it a case of deleting all those edges then redrawing a flat face?


#8

It looks to me like you’ll have to go several steps backward and redo a portion of the model. Like you said, you probably missed selecting some edges or points before you performed a move, and some inadvertent auto-folding resulted. Check out this GIF where I run some lines along axis to show how your walls and foundation are skewed.


#9

Those two corners are out by 9.73mm. Easily fixed with the move tool.
Use the right arrow key to force along the red axis.

Shep


#10

@Shep that worked, thanks.

But how did you work out which edge or node required moving? There are a couple of other places I need to rectify similar problems.


#11

Perhaps I’ve looked at too many troubled models, but those fold lines just sort of point to that corner.
You can also use the query tool to examine the x,y,z coordinates.

Shep


#12

If you go into the “in model” “edge Styles” tabs as shown and select “colour by axis” , the edges are then literally coloured by the axis they are on. In my little example below you can see two of the edges are not on the blue axis as they should be. This then gives you an area to start investigating. It can be useful sometimes.

LATER EDIT: With the link that Shep has posted below, the colour by axis method can actually miss off axis items in some cases. The query tool (to me) should be considered a more serious option to find these errors, as already recommended by Shep earlier.


#13

@Thorleyian Thanks, that was helpful. In one particularly difficult case I ended up deleting the face and starting again, it wasn’t so hard. I couldn’t work out how to align one of the edges to the vertical axis. But now it’s good.


#14

Good to hear it was useful, I found it out reading this forum. You should stick around, you can learn some great tips.


#15

Everyone should be aware that color by axis has limitations however.

Shep


#16

SU itself has a certain tolerance for off-axis / non-coplanar edges supporting a healable face.
Style > Edge > Edge Color by Axis was fixed in SU 2017 such that it reflects SU’s inherent tolerance.

See the the attached model.
Edge Color by Axis_SU 2017_Test.skp (84.9 KB)

This, from the SU 2017 Release Notes:

● Fixed an issue where, when using color by axis, lines could incorrectly display as if they were on axis when they were not.


#17

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.