Fbx export has only one pivot point 0;0;0 for all parts in the model

When I export a model in fbx with more than one group (for example 2 chairs and a table) the fbx file does not show the pivot point of the seperate groups. You would have to rotate for example the table around the main axes of the model. This is not very handy. Is there a solution to export it so that each group has its own pivot point?
I already found a possible solution to make every seperate piece a component, but this is very timeconsuming, as I make models of houses I would have to make each wall, window, plant, detail a seperate component…

The FBX you export should have heirarchy, based on your use of groups and components. Whatever tool you use the FBX in should be able to rotate parts based on the part’s center.

Here’s Unity doing that. As you’ll see, the legs should have been inside the chair object, but otherwise it’s working ok. I didn’t record it, but you can also select individual meshes, and rotate those. In the export options make sure to use the Separate disconnected faces, to give you more independent meshes to manipulate.

1 Like

Thank you for the response however this does not work in my case. Could I download this model from the video to see how the hierarchy was build?
Also the fbx file is loaded in Cinema 4D, not in unity, maybe that makes a difference?..

You can take a 3D model from 3D Warehouse, export it as an FBX file and test it.
In Unity 5 it works ok

Hi,
Are all these models components, or are they groups? Because Groups don’t have their own pivot points when I export to fbx and import in cinema4D. What happens in cinema4D is that if I were to click the chair, I would get the main pivot point, same with the table and vase. I don’t know if I’m doing something wrong or if it is just not possible?..

I gave you the direct link to the 3D model in the 3D Warehouse, you can easily check if it is made up of groups or components. In the example I gave you (GIF), one (vase) is a group and the other (chair) is a component.

For Cinema4D search Youtube for tutorials

What you say about Cinema 4D seems to be correct. I learned more about Cinema 4D just now than before this in my life!

The solution is to select what you want to pivot, go Modes, Enable Axis (or press L). Now you are manipulating the axis point of the selected objects. Move that to where you want to rotate, then press L again.

Hey, I ran into the same issue and having some following questions.
The pivot point looks ok in this case because Unity was using “Center” mode instead of “Pivot” mode (next to the toolbar on the upper left). When I switched to “Pivot” mode, groups/components were sharing the same pivot point with the root in Unity, even if I did something with it in SketchUp (more specifically, change axis for components). What exactly does “Change Axis” do then? Does it really change the pivot point of the mesh (which can be used in other 3D packages) or is it just something that only works in SketchUp?

Whalex, from what I tested now, the place where you set the axes in SketchUp is recognized in Blender if you import the SKP file directly.

I tested with Unity 5 and imported OBJ file, which was exported from SketchUp, the place where I placed the axes in SketchUp was not maintained. If I need it, I create a GameObject, to which I set the pivot as I want, and I put the model inside this container.

You can test to see what happens if you directly import the SKP file, but in a version greater than Unity 5.6