Export to cura resizes 3d model

Recently when I export a 3d design to stl it is dimensionally changed. The model I am currently working on is a scale model of a train station. I designed it full size, the length being 58 feet. When I export it, then open it in Cura the length is 696 mm so scaling it is very difficult. I am trying to make an HO scale model 1:87.
Any help would be appreciated,

.stl files have no dimension units. In this case it would probably be easiest to scale your mdel down to 1:87 before exporting the .stl. Modeling at full size is a good idea because it doesn’t require any math to get dimensions correct. Scaling down before exporting is quick and easy.

Thanks for response. I thought that would be an option but in the past I had no problems scaling in Cura, thought maybe something had changed.

I guess I can’t say anything about Cura. Maybe you can still do the scaling there. Of course that wouldn’t a SketchUp issue. SketchUp only exports the geometry as it is.

I tried a couple of experiments, made a cube in inches which when exported to stl, it converted 10 inches cubed to 10 mm cubed. I also tried a 1 foot cubed and the stl file was 12 mm cubed. I used the template Simple inches, then 3D Printing inches and both converted to 10 mm. Then I tried 3D Printing millimeter which converted correctly.
On the conversion feet is being converted to inches and inches being called mm (not converted by multiplying by 25.4).
Sizing it in Sketchup when using feet or inches will not work correctly. I don’t think this is a Cura problem or am I missing something?

I think you are missing something. Here’s an example.

I modeled this crank handle with units set to meters. Exporting the .stl using Model units which only means that 0.76 is 0.76. There’s no units actually used in .stl files.

Here I’ve uploaded the resulting .stl file to i.materialise with the import units set to inches.

Here’s the exact same .stl file imported using millimeters as the import units.

When you import the .stl into Cura, you need to choose the appropriate units for import. I don’t use Cura so I can’t advise you on how to set the units.

Cura is set to use MM and is unchangeable.

as Dave said .stl is unitless, it just records a number for a given dimension, not a size. So if you are modeling in inches and make something 12 inches it saves as the number 12. When you import to cura MM gets applied, in this case it becomes mm. You cannot change this setting in cura it is by default MM. So you will need to scale the SU file first.

EDIT: looks like there is a Cura plug in appropriately called Barbarian Units if you really want to work with inches in Cura, I have not used it

1 Like

Thanks for the response. The more I thought about the more apparent it became. Seems to me to be a major flaw in the system. I am trying to model a old railway station which is 58 feet long. This means I will have to multiply 58x12x2.54=17,678.4 to get mm and then divide by 87 to get it to HO model railway scale for one dimension. Seems complicated. I do appreciate your help.

Hmmm, just thinking this through. How about this, before exporting change the units in SketchUp to MM (size of the model is unchanged, just the units). Then scale the whole model down by a scale factor of 0.011494252873563. This is 1 divided by 87, I think I’m doing this right :thinking:, then export. This should give you a .stl that is the correct size ready to go in cura.

If there’s a flaw in the system it’s not in SketchUp or in the .stl export. It would be useful if Cura had a way to adjust the scale of the imported .stl file (i.materialise offers that option) so that you could choose the appropriate size for the printed object. As I wrote ysterday, it’s usually much easier to model at real world dimensions and then scale afterward. If Cura had a way to set the import scale the same .stl file could be used at 1:87 for HO or 1:148 or 1:160 for N or whatever scale one needs. Some years ago I used a model from the 3D Warehouse to create a card stock model. I left the building at its real world size and unfolded it. Then in LayOut I set up the scale for the scene/viewport to suit.

This could be printed to suit any model scale by simply changing the scale in LayOut and adjusting the paper size as needed.

Wow, great idea, I didn’t realize you could just change the units. I’m going to try it right now.
Again thanks,

1 Like

Your first export was probably using Inches as the unit (696 is the length of your building in inches).

I looked at changing the units under Window, Model Info, Units but I don’t see a way to change it.

The i.materialise, is that another slicer program?

Screenshot - 9_17_2021 , 11_53_26 AM

Change the Format to Decimal and the Units to millimeters.

i.materialise is a company that offers 3D printing services. They do a very nice job in a wide variety of materials. I use their site as a way to check models and to demonstrate what I showed previously.


Meters to inches: X .0254
Meters to feeet: X .3048
Feet to inches: X .0833
Inches to meters: X 39.3700787
Millimeters to Meters X 1000