Export geo located KMZ and then import the same file looses geo location


#1

Ohoy!

I’m having trouble with geo located KMZ imports and Sketchup Make 2014, 2015.

Test:

  1. I made a simple volume and geo located it with Sketchup
  2. In Sketchup, Model info->Geo-location shows that the file is geo located
  3. I export as KMZ and verify with Google Earth that the file shows up in the correct position
  4. Then, in Sketchup - I made a new file and imported the same KMZ file that I exported and verified.

Model info-> Geo-location now says that the model is NOT geo located.

Is there a fix or workaround to this issue?

Thanks!


#2

Yes.
Model info — Geo-location — Advanced Settings > Set Manual Location
Notice the L,Lo fields in the Set Manual Location dialog have been prefilled with those of the KMZ.
Click OK


#3

Hi, thanks for your reply.

That workaround breaks when importing several geo-refed models into the same scene.

If I import a georef KMZ with a model in origo, and then import another KMZ with model in origo but other geolocation, they both end up in origo and the coordinates of the scene is from the first KMZ import.

In Sketchup 8, it works as expected -> The georef is from the first import, so the second import gets positioned relative to that and not in origo.


#4

By default SU 2015 behaves this way in a new model file:

Click… Model Info > Geo-location > Set Manual Location
The Set Manual Geo-location dialog appears and it is prefilled with the default location.
40.018309N 105.242139W (SU Home Office, Boulder Colorado)

Notice if you click OK in the Set Manual Geo-location dialog, nothing happens.
That is, the Model Info-Geo-location panel still states…”This model is not geo-located”

Now make a change to either or both of the L - Lo settings in the Set Manual Geo-location dialog.
Then click OK in the Set Manual Geo-location dialog.
The Model Info-Geo-location panel then states…”This model is manually geo-located”

I have no ‘official’ knowledge of why it works that way.
Perhaps it’s to keep inexperienced users from inadvertently geo-locating their model.


How To:

After you import the KMZ, go to the Set Manual Geo-location dialog.
Make a notable change to one of the L,Lo values. Say, change the L by 10°
Then click OK … Model Info then says the model is geo-located.
Then go back to the Set Manual Location dialog and change the L to the previous (correct) value.



#5

Thank you. That almost works :slight_smile: The altitude of the second imported KMZ doesn’t seem to be correct. I have to do more tests. But this seems like a Sketchup bug since it works in previous versions without workaround.


#6

Continuing the discussion from Export geo located KMZ and then import the same file looses geo location:

where i can find geo location plugin for skp 2015?


#7

Google disabled the Google Maps interface used by the geolocation function prior to version 2017. From version 2017 on SketchUp uses Digital Globe data, but there is no fix for earlier versions. The only extension I know that replaces the geolocation tool with its own is PlaceMaker, but according to the Extension Warehouse it works with v. 2016 and newer.