Evaluation time error


After every few clicks while using Sketchup 2014 (basic, not Pro) I get this error message:
Unable to update the evaluation time. Make sure that C:\ProgramData\SketchUp 2014\SketchUp14.lf is writable.
By clicking OK I can continue normally and everything is saved, but working this way is awkward and you lose concentration. I have checked the file’s attributes and permissions and everything looks fine. My machine is a Windows 7 64-bit.
Is anybody else experiencing this and can contribute any solution?
Thank you!


Can you check if that mentioned file is read only or not?

  • Copy-paste
    C:\ProgramData\SketchUp\SketchUp 2014
    into the Windows Explorer address bar. Hit Enter
  • Right click on SketchUp14.lf, click Properties.
  • Make sure the Read-only checkbox is not checked.
  • Click OK to dismiss the Properties dialog.
  • Run SketchUp


I did check the file for being read-only before posting this, and it was not. Permissions were ok (full) too, so I decided to uninstall and repeat the install, this time as an administrator. The problem persisted so I was about to step back to a previous SU version, but first I shot my last bullet: running SU as an administrator, which solved the problem. I had tried the same with the previous installation (which was not done as an admin) with no luck.
Therefore, according to my experience, if you get that message you need to re-install as an administrator AND run Sketchup as an administrator, too.
Thank you very much for your post.


Thanks for posting the resolution. We will investigate and find out what we can do to fix this.


What can be done if running as an administrator is not an option?


I experienced the same problem on a Windows 7 32bit lapop.
I was running SU 8 without any problems. But then had to install a newer version, because I wanted to open a drawing of mine I made on another pc with a newer version.
So I installed 14 free version last week.(ran setup as adminsitrator)
But running SU not as administrator I also get this message every couple of minutes. Running as administrator this message does not come up.


for allowing the installation and product activation to work, under Win Vista/7/8 installation and first run should be done with admin. rights by e.g. right-clicking and selecting 'Run as admin…".

The default user of Mac OS X does have admin. rights already, therefore nothing special to do on this platform… besides if running a limited user account.



Thanks for your answer. I followed these instructions (install & run once as administrator) but still get this annoying popup!


Me too. Besides, I can’t even uncheck the checkbox, because it i click ok and re-enter the properties screen, the box is checked again.


2015, I am having the same problem and trying the fix suggested did not help.
Has anybody found a working alternative to avoid having the same message pop up every couple of clicks? It does hinder the workflow enormously…
ta in advance!


Have you tried this?