"Error reading layout files" twenty + times upon opening layout

Yesterday, upon opening Layout, I was greeted with an “Error reading Layout file” message referencing a particular (layout) file. I clicked “OK” and was greeted by another, and another, over twenty in all. After clicking ok to each of them, finally the document setup window appeared and ran through a handful of files, one after another. When it finished I clicked ok, and there I was in Layout, with the file I had intended to open.
THEN, the next day, all my toolbars reset to the default setup.
I have no idea where to start. Help would be very much appreciated.

Questions for you.

  1. How many SketchUp models are you using for the LayOut project?
  2. How many SKP files are listed in References?
  3. When you installed SketchUp and LayOut did you right click on the downloaded installer file and choose Run as administrator from the context menu?

Dave,
Thank you for your fast reply.

  1. Each of these LayOut files references its own single SketchUp model.
  2. Each LayOut file, as it races through the document setup window, shows only the single SKP to which it is linked.
  3. I did choose Run as administrator when I switched to 2019.
1 Like

Are you using Send to LayOut from SketchUp or File>Insert from LayOut to insert the SketchUp files?

Are there other files in references? Do any of them show as missing?

When you close the file and open it again do you get the same error message?

Which 2019 version? 2019.2?

I use File>Insert to bring the SKP into LayOut.
These LayOut docs only reference SKP’s.
When I close and open the same thing happens.
2019.2.222

This is weird. Are the SKP or LO files store in some sort of cloud location?

They are on my one drive, which I think means they’re on the hard drive and the cloud, but I’m not sure. I’ve had it this way for over a year and nothing like this has ever happened. I also ran Windows system restore but that didn’t help. It is so very weird.

It is very weird.

I would first make sure that the files are all stored locally and that you are only syncing to One Drive. We have seen reports of weird problems with files that are stored on One Drive or in other cloud locations. It seems that sometimes access times are too long and that creates issues. You might try copying the files to a known local directory at least for a little while and see if the behavior changes.

will do.
Is a reinstall in order?

I don’t think so but it’s kind of like chicken soup. It couldn’t hurt. Instead of a reinstall, though, you could do a repair. Right click on the installer, select Run as administrator again but when prompted, choose the Repair option. You won’t lose any customized stuff that way.

Then as far as your files go, it seems to be best practice to save all of your files locally and only back them up by saving them to the cloud. Don’t save directly to One Drive from SketchUp or LayOut. There have been some reports of things going pear-shaped with saving files directly to One Drive, Drop Box, etc. The files end up being modified somehow in the save process and are no longer readable at all. i don’t think you want to take a risk of that happening either.

Thank you Dave.
Will do and check in tomorrow.

1 Like

Update:
Took the chicken soup and relocated files. No change.
HOWEVER:
Went to preferences and changed what LayOut does at startup from “Re-open files from last session” to “Don’t open anything.” Seems to have fixed things, if only a work-around. (Extra) weirdly, the files that LayOut found errors with are opening perfectly.

Dave, thanks for jumping in fast, even if the mystery remains mysterious.

Hmmmm… Do you really want it to start up all the files you might have had open during the last session? I have LO set up to Show the Welcome screen on Startup. That’ll let me choose the file I want to open instead of opening all of them. What if you make that setting? Does LO still give you that message when you open a file?

If it’s trying to open a file from the cloud, could it be giving that message at first because the access time is too long?

Welcome screen works. That seems like the best option. Access time issue seems unlikely as the connection here is super fast and I’ve not had the issue in the past.