Edit how Sketchup creates segments from .dwg files?


#1

Hello everyone,

I was please wondering if it’s possible to edit how Sketchup builds’s imported .dwg’s. It seems from this vector I exported to .dwg and then opened in Sketchup simply just uses far too little segments to create the curves from the original file.

So is there a way to increase the number of segments it uses to build curves from imported .dwg’s? Just like we do while making curves/circles inside sketchup? Or has anyone found any particular settings/templates, or specific export parameters that reduce the distortion of .dwg’s?

Thanks,

Rick


#2

Nothing I can find in the Import or Export Options child-dialogs.

(Moving to Feature Request category.)


#3

Are the parts of the linework ‘curves’ or ‘arcs’ ?
If they are arcs and they do not form part of a 3d form you should be able to reset them in Entity Info to have more segments…
If there are lots like these I wrote a script ages ago [therefore it’s clunky and ill-formed - but it still works].
It lets you select a load of these arcs and reset their segmentation en mass.
http://sketchucation.com/pluginstore?pln=ArcCurve_set_segments
You can run it from the Ruby Console, or much easier - use the Plugins|Extensions menu item to run it and set the segmentation in the dialog that opens…


#4

Thanks, I always though it would be handy to be able to set arc and line segments in preferences and keep the settings.
Just my two cents worth.


#5

@durrroy
It is quite possible - at least on a PC.
I recall someone once wrote a script that loaded as SketchUp started, using a dll that mimicked key-strokes for C and a numberS and A and a numberS etc and reset the default segmentation for Circles and Arcs.
I think it used a dll that is now out of date with newer SketchUps…
It’d be possible to replicate it, BUT I think that, as with several other things - like length, area and volume unit defaults - it should be [re]settable in either the main Preferences or possibly within Model Info, and then changeable in each Template/SKP…


#6

Which should have precedence ? The user setting or the model setting ?

If the user loads a model they got from somewhere else, they’d likely be unhappy if their global preference was ignored.
Or should the user global only override new models from templates ?

Would the model setting have an “undetermined” / “default” setting (nil or whatever,) that would be automatically overridden by user preference, but if otherwise set would not ?


#7

Thanks for the insight, appreciate hearing from you experts. :grinning:


#8

I think I found the problem. It’s not that Sketchup is forcing a small amount of curves. I think it all starts with the number of anchor points in the illustrator vector. (forgive me if this is common knowledge to everyone else, I’m very new to illustrator and sketchup).

It will probably be easier to just draw this design in sketchup, but I may be interested in finding out how to add more anchor points to other vectors that I like for importing.

Here is an image showing that I only have few anchor points on the vector. So is this why sketchup is just making straight lines from anchor point to anchor point?


#9

In Illustrator, do Object/Path/Add Anchor Points, a lot of times. That seems to help. No need to use straight lines.


#10

Thanks. I’ll try that.


#11

I would say “a few times”, no reason to overdo it. As Colin says, straightening the resulting segments is optional.

I guess not quite - SketchUp is just not making a very good job of approximating spline curves out of DXF imports. If I compare your two screenshots, it looks rather that SketchUp is trying to fit arcs with too few segments between those anchor points. I wonder if using a larger import unit (for instance, Meters instead of Centimeters) would improve this a bit, You’ll find the unit setting behind the options button on the Import File dialog box.

Anssi


#12

Yes, you’re right, I went back and tested with only a few extra anchors, and it already made a huge difference, I didn’t need to add quite as many as in my first test!


#13

I just did the “add anchors” object path in illustrator, but I only did your first suggestion so far where I added it several times, I think 4 times I did the “add anchors”.

It worked perfectly. My DWG file imported with PERFECT curves.

Thank you guys