Dynamic Components shift strangely when updated/changed

advice
bug
components

#1

Sometimes when I import a component (or have just been playing with a component for a little while) an attempt to update/change it (e.g. increase its height) causes one of the groups/components within it to inexplicably shift to another position.

For example, today I was working with a set of drawers, and whenever I tried to input a new material for the draw front, the draw front itself would shift down 30mm and then refuses to return. Undoing back to the state where it had not shifted was possible, but repeating the action just gave the same result.

I’ve had this happen to other components before and have sometimes had success by simply restarting SketchUp. But today’s particularly belligerent drawers made me wonder if there is something else I should be considering?

If you have come across this problem and have found anyways to fix/cope with it, I would be very glad to hear your advice! Cheers :slight_smile:


#2

Without the components and file can only suggest

When this happens, check the info tab to see whether there is more than one group or component selected, sometimes components do not become unique and groups are very unpredictable as they can retain a link to the original. If more than the expected, make the component unique or change the group to a component.

Its good practice to build within the same environment, as switching to another, doing changes, then bringing it back in to same, or placing two amended items that have the same starting component in the same file can produce this effect.

Most likely the reason would be the component is updating to the current nesting/parent relationship, try exiting the component and do a redraw to see if the position corrects its self. This maybe avoided by checking if the current parent option dialog is visible, specially required if making an alteration, as the position is in reference to this parent, otherwise its going to fly off to some original reference.
Axis changes (rotation) can complicate this reaction, like position its in reference to the parent, whereas size is in reference to the child
Can the material be changed at the highest level, without going into the nested level? like a swatch that the lower subs reference


#3

@pcmoor Having played with the model a little more, it seems that it is usually specific components that go haywire, which going off your advice makes me believe we might have built those components poorly in terms of referencing. This particular mischievous drawer has a rather complicated build, so it is a kind of annoying to bugcheck, but I think my best solution will be to check or rebuild, making sure it is cleaner this time.

And as for your material question, I believe (although not entirely sure) that we did change it at the highest level, which is what made it all the more confusing haha. But thank you for your comments anyway, they very much helped! :slight_smile: