.dwg import

I am using SU2021 Pro on a Windows PC

In the work that I do - I often import .dwg files (that have been already been exported from a native Revit/Autocad environment) - and - that has always worked fine for me.
I am now trying to import into SU a .dwg that has been created from a native Microstation/DGN model - and - I am having problems!

Most of the model ‘come in’ to SU - but - there are bits that ‘are missing’

I have tried isolating some of the stuff that is ‘missing’ - and have a .dwg that has what I want (I can see it in the Autocad software) - but - when I try to import that file into SU - nothing seems to be there.

Could you show us an example file that has problems?

I once made a test file in AutoCad for testing the import of all AutoCad primitive types I remembered into SketchUp. This is what it looks like in DWG TrueView:

And this is the result of importing into SketchUp:

The result is fairly good overall. When 3D primitives fail to import the reason is often the small faces dilemma. Using a larger import measurement unit (centimeters instead of millimeters, for instance) often helps. Note that reference files and objects that require an object enabler in AutoCad (like AutoCad Architecture walls) do not import.