Drawing problem, surface changes into multiple polygon

Hello everyone,

I’m having a problem with one wall in my drawing.
Suddenly the surface on both side of the wall changed into multiple polygon pieces.
In previous version of my drawing that I saved, the wall is still normal.
I tried to copy the previous wall into my current drawing but it automatically changes into the te same problem. I can’t redraw the wall without the problem. Saving it into an emty file isn’t helping also…
I restarted my sketchup and computer… isn’t helping.
Enyone an idea what to do?
Thanks a lot!

Yes, uploadinging the model might help to get a proper answer. It would be just guessing now.

While we are guessing, how far from the origin is the wall? How was the wall first created?

The drawing is close to the origin. I noticed that the ‘change’ between normal wall and corrupted wall happens when I save…

Still guessing but I expect SketchUp is fixing problems during the save process. Very likely you are seeing issues with very slightly out of plane geometry. If that’s the case the best thing is to fix the model, which may require redrawing some of it, but you could go to Preferences>General and disable automatic fixing of the model.

If you share the model like @Wo3Dan asked, we could quit guessing and give you a better answer.

DEVRBDPOUB - 20200521 - 3d forum.skp (307.5 KB)


You are not using Layers [Tags] correctly.
The active one should always be Layer0 [Untagged].
Create all of your edges and faces, assigning them that layer.
Make a Group/Component of logical related geometry and assign another Layer [Tag] to that ‘container’ - you then use that to control visibility by toggling that Layer [Tag] on/off.
Having ‘raw’ edges and faces using different layers/tags is going to trip you up - as it doesn’t separate the geometry even though some of it might them be hidden from view.
You have also used ‘Hide’ on some unwanted edges that split faces - this is ignoring the problem rather than fixing it, and down-the-line it will make unexpected problems…

You can use Entity Info to reassign the default layer to edges/faces.
Some of your out-of-plane faces will need remaking - easier to do inside a ‘container’ as the inherent ‘stickiness’ of SketchUp’s geometry is broken by using ‘containers’ - unlike using ‘layers/tags’

1 Like

problem solved, thanks alot