Drawing a roof with pitches at right angles


#1

Sorry, not sure of the actual term. See:

In the foreground is a ground floor extension I will eventually connect to the main house.

On the left is a shallow pitched lean-to roof. On the right is a room-in-the-roof.

I drew the roof in the roof first, then pulled up the edge to form the shallow lean-to.

The problem is the extra angle introduced when moving the edge to form the shallow lean-to roof. There should only be three roof faces. An extra edge was introduced on the roof between the shallow roof and the room-in-the-roof.

Sorry, this stuff is hard to explain (for me without the vocab).


Can't move edge up (to draw roof) when shape is connected to another
#2

In your image it looks as if the ridge of the gable and the edge at the end of the low-pitch roof are not parallel (which would be the case if the ridge is horizontal but the edge is sloping). If you delete that edge and both faces disappear, that is proof. A face in SketchUp must be planar. Just as in real life, you will need a more angled join (hip) where the plane of the gable meets the plane of the low-pitch roof.


#3

Hi there,

If you did something like this;

You can do something like this to form the valley;

Shep


#4

you can group the existing roof, move the lean-to ridge line to your height, select nothing then move the point at the end to refer with exist roof, then clean up, this will stop the autofold


#5

@Shep, nice animation and solution.
Also see my reply here about moving a vertex: Joining in-line lines
See how you can apply it here to speed up getrting the end result without drawing extra edges plus deleting some others.

Use/drag the vertex (where you extended the edge) to ‘Constrained to Line Intersect Plane’, to intersect the gable roof plane


#6

Good Point @Wo3Dan ,

I think this is mostly what you mean.

Shep


#7

Correct. But I failed to mention that before actually “grabbing” and dragging the vertex one should hover over the edge and when seeing ‘On Edge’ holding down [Shift]. Only then grab the vertex.
This makes inferencing to the face easier.


#8

For whatever reason, gifcam does not like doing it that way.
Anyone know the cause of the green?

Edit: Here’s a go with green screen turned off. See below.


#9

It looks like the right sequence.
And no, I don’t know what happens with the green screen.
But in SketchUp itself, did you get the cursor tooltip ‘Constrained to Line Intersect Plane’ as reference?
I hope so.

Yes, I’ve seen it for a split second.


#10

it’s just the gif getting confused…

john


#11

Got it! Thanks everyone.

It took a couple of tries to get the right combination of hover time (I’m still new to this). A few times the eraser removed the entire roof section. But I got it eventually.


#12

You can usually correct that by going edit, then right click and change the green screen colour. Doesn’t always fix it.


#13

Thank you,

I just un-checked the green screen option. Seems fixed.

Shep