Draping pictures on a 3D textured mesh

I am been unsuccessful in trying to drape a picture on a 3D textured mesh (irregular rock surface). I have tried the Drape Tool shown online. I am a new user working in SketchUp 2019.

Have you softened & smoothed the mesh ?

I just tried to drape my log data onto a cylinder I drew. It still did not work. At least this time the cylinder turned blue (the rock outcrop never turned blue) when I hovered the drape mouse over it.

Maybe the software does not like my jpg or png files that I’m trying to drape onto the surfaces?

Try this method…

This works, but it requires that the image is the same size as group (i.e. the upper surface and the lower surface are the same size). The image I need to drape is much smaller than the 3d model I am draping it on.Drape

1 Like

I can drape my log data onto a cylinder, but when I try to drape it on the rock outcrop nothing happens. The rock outcrop is an .obj file I imported using the SimLab OBJ Importer.

It looks like the drape tool in SU only wants to drape the image onto a group of approximately the same size. This will not work for me.

Kindly pay attention to terminology.
It’s difficult to help and forces us to guess when the words don’t make sense.
There is no mention of of the term ‘drape’ in the tutorial I linked above.

The process in question is termed ‘projecting’ a texture.
The term ‘drape’ is a function of one of the Sandbox terrain modeling tools, i.e. the Drape tool.

Keep the Entity Info dialog open as you’re modeling.
That way, it’s easy to learn what you’re working with.

Select the imported geometry.
Most likely Entity Info will indicate it’s a Component.
Opening the Component for editing enables you to work with the geometry inside.


The method of draping geometry illustrated by @mihai.s works, but there is a catch.
The Drape tool only works vertically along the blue Z axis.
That is, the geometry you wish to drape must be directly above the mesh you wish to drape it upon.
Try rotating the ‘whole works’, then drape, then rotate back to normal orientation.

1 Like

Yes, terminology is important. As a new user I must learn the terms.
When I select the 3D rocky surface I imported, it is identified as the Component in the Entity Info Dialog box. When I select the imported Log data (smaller white rectangle with zig-zag lines) it is identified as an Image in the Entity Info Dialog box. I want to project the image onto the component.

I was not successful at projecting the Image (texture) onto the Component using the method provided by @mihai.s. However, when I created a new Component in SU (a cylinder) I was successful at projecting the Image onto the new Component (cylinder). However, unfortunately the Image was projected across the entire new Component (the cylinder). The new Component (cylinder) is much larger than the Image. The original Component (rock surface) is also larger than the Image. I am not allowed to change the relative size of the Image or the original Component.

Based on the way the Drape tool seems to work, the only way I think I can accomplish my task (project Image on Component) is to:
2.) Rotate Component 90 degrees > import Image > Crop the Component to the same size as the Image (can I do this?) > project the Image onto the cropped Component > rotate the ‘whole works’ back to its original vertical position.
The only problem with this method may be that I might not be able to return the Component and Image back to its exact original position. Also, I am still unable to project the Image onto the original Component. Dan suggested I try to smooth and soften the original Component. I did this and am still unsuccessful.

Thank you for your kind assistance

1 Like

Here is another option where you don’t have to rotate the terrain.

2 Likes

I could follow what you are did up to Intersect Facies > with Model, then you:
1.) Clicked outside the model area
2.) Then you selected the Image > Edit Group
After this you somehow pushed the extended Image back to its original position, but you didn’t use the Push/Pull tool. How did you get the Image back to its original position?

I selected those edges and faces (without ‘the image’) and deleted them with Delete key.

I was successful in duplicating your flow by projecting my texture onto a rectangular block I created in SU, but the flow would not work on my 3D model I imported from Pix4D.
Thank you